1. htmanning's Avatar
    I had to completely restore my iPhone 4 which meant I lost my jailbreak and am now on 4.3.5. I have my ssh blobs from 4.3.1 but I don't really want to have to go back there. All I need the jailbreak for is BiteSMS so I tried the Redsn0w tethered jailbreak. I got Cydia on there and was able to reboot tethered, however after installing BiteSMS and hitting the "Restart Springboard" button the phone was stuck on the Apple screen. I had no choice but to completely restore AGAIN.

    So now I'm nervous about doing the jailbreak again. If I use Redsn0w again and install BiteSMS, do I just shut the phone down without clicking on the "Restart Springboard" or am I supposed to restart the springboard? I'm at a loss as to why my phone would hang afterwards if the jailbreak works.

    Thanks.
    09-22-2011 05:28 AM
  2. Massie's Avatar
    Were you respringing or rebooting? Rebooting on a tethered means you have to hook up to your computer and run the "boot tethered" option in Redsn0w every time you reboot.
    09-22-2011 07:48 AM
  3. BLiNK's Avatar
    if i remember correctly after you jailbreak (tethered) you will have to run a tethered boot to get Cydia to work properly. the same process will need to be done after installing biteSMS, and other certain apps/tweaks

    which, if i read the OP's post correctly that's all that originally needed to be done instead of restoring. any time your phone reboots, on its own/or by accident then showing the Apple logo, you can just simply hook up to your computer and run the redsn0w program and select the tethered boot option

    hopefully someone can verify this. it's been a while
    09-22-2011 08:08 AM
  4. htmanning's Avatar
    I did hook my phone up and run Redsn0w but it wouldn't allow me to reboot the phone. It was stuck on the Apple logo and no matter what I did, I couldn't get past it, except if I took it into recovery mode and then restored it.

    I jailbroke it, tether-booted it with Redsn0w and Cydia was there. I went into Cydia and installed BiteSMS. It finished the install and asked me to restart springboard. I hit "Restart Springboard" and got the Apple logo. After that, I couldn't boot at all even if I ran Redsn0w again. It couldn't find the phone.
    09-22-2011 03:38 PM
  5. BLiNK's Avatar
    have you been putting your device into DFU mode? if you're not sure about this process google it. plenty of info out there and YouTube vids on how to do it

    even when the Apple logo is present you can still put the device into DFU mode
    09-22-2011 07:06 PM
  6. pecker115's Avatar
    I had this problem too on 4.3.5, dnt respring but turn phone off and then re run redsn0w and run just boot tethered option, thats only way i could get it to work
    09-25-2011 06:26 AM
LINK TO POST COPIED TO CLIPBOARD