1. Rocket_ron's Avatar
    I am a new user and this is my first post, so let me start by saying hello to all of the members here.

    I moved out of the USA about 20 months ago to a country in the south Pacific. Before I left the USA, I downloaded and used "Blackra1n" on my two iPhones 3G. So I am still using them in that 3.1.2 update and Blackra1n.

    Somewhere along the line, I have lost the 2 SIM cards that I had for the ATT service in the US, and I can not find them anywhere. I do have SIM cards for 2 local services here that I use regularly

    Is there any possible way to remove Blackra1n without having the ATT SIM cards? I am afraid to try for fear of "bricking" them, as I have seen so many times people saying that this has happened.

    The reason that I would like to remove Blackra1n is so that I can update both phones to a later version in order to use some apps that will not work on 3.1.2. Of course then I would want to unlock them both again so I can continue to use them here.

    Any reliable help would be seriously appreciated.

    Thank you all.
    08-22-2011 02:33 AM
  2. Peligro911's Avatar
    You don't need them just update the software with snowbreeze so it don't change the baseband ... Snowbreeze with activate the phone so you won't need the att sim cards once your updated just use Cydia and install ultrasnow to unlock them so your current sims will work
    08-22-2011 03:06 AM
  3. Eileen89's Avatar
    As was mentioned above, as long as you don't change the baseband you'll still be able to unlock and use another carriers sim card.
    08-22-2011 05:03 AM
  4. Ipheuria's Avatar
    DON'T UPDATE YOUR FIRMWARE!!! I have had every iPhone so far except for the 3Gs. So beleive me when I tell you that on an iPhone 3G 3.1.2 is the BEST firmware. It is stable, runs quickly and the others while they have additional features will slow your phone down soooooo much. So if you want my honest advice do not upgrade the firmware if it has been working and you love it keep it. The only thing you need to do is unlock the phone this will enable the phone to run with the SIMs you have and it's an older phone so most likely you wont have any problems. So go to iClarified - Apple News and Tutorials and look under tutorials, iPhone, Unlock and check to see if your baseband is unlockable and follow the simple steps to unlock it.

    You could also use Pwnage Tool(Mac) or Sn0wbreeze(Windows) to redo a custom 3.1.2 firmware and reload your phone. When you're doing the steps make sure the software is in Expert mode and make sure the "Activate this phone" option is checked. This will allow your phone to work no matter which SIM is in it. These software will wipe your phone so before you begin make sure you do a sync and a backup. Once you're done go through the unlock steps again.
    08-22-2011 08:39 AM
  5. ckalli's Avatar
    i have a factory unlocked iphone4 on 4.2.1 is there any way to upgrade it to 4.3.3 so that i can jailbreak it with jailbreakme.com?
    08-22-2011 01:09 PM
  6. Ipheuria's Avatar
    nope Apple has stopped signing 4.3.3 and if you're on 4.2.1 then you probably don't have SHSH blobs saved for 4.3.3. Why don't you just JB on 4.2.1? Go here iclairified.com and look at Tutorials, iPhone, Jailbreak then look for 4.2.1 do the JB then in Cydia look at the top and see which SHSH blobs you have saved. If you have 4.3.3 then you can download the ipsw file use Tiny Umbrella to point to the Cydia servers and then do the JB after.
    ckalli likes this.
    08-22-2011 04:39 PM
LINK TO POST COPIED TO CLIPBOARD