1. kylezo's Avatar
    Hello everyone!

    I could really use some help. I got a jailbroken 3GS from craigslist recently, and I have learned that the previous owners had the battery replaced. When I got the phone home, I decided to wipe it and jailbreak it myself.

    So I go into iTunes to restore to 4.2.1, planning to redsn0w JB afterwards. i get a 16xx error...nothing unexpected. I get back into the shift+restore process and this time, I get an error 29. Did some research and found that this is a hardware error usually relating to the battery. At this point I couldn't get anything, jailbroken or not, onto the phone to get it running again. So, I download every jailbreaking and modding program I can find to try and get it working. Eventually, using greenpois0n, I was able to get the phone running. This whole process took me about 6 hours.... yikes. At first, after finally getting the phone running, I had no service. Used multiple SIM cards that worked in other phones, etc. AT&T said the phone wasn't showing up on it's towers at all...eventually I went through the restore/16xx/29/greenpois0n process again to get it back up and I had service.

    So finally the phone is working (4.2.1 greenpois0n). I wanted to restore on top of the greenpois0n install, cuz I don't like the little custom boot logo, and I don't really know jack about greenpois0n or how it works. But, I am repeatedly frustrated by the error 29, so I settled for it.

    Now, I'm having problems sending and receiving MMS picture messages. I don't know what's wrong but I've been on the phone with AT&T already and everything 'seems' to be correct. I presume it's a software problem because of the weird setup process I had... I will get a 'message' when someone sends me a picture, but it's just the little arrow, and no thumbnail, and when I click the arrow its just a blank screen where the picture should be.

    ****tl;dr****
    I can't send/receive MMS messages and I'm not confident I can restore/re-jailbreak correctly...

    SO, now you know a bit of the history, I'm hoping someone can help me out with some info. Why is greenpois0n able to bypass/work around this hardware fault error from iTunes? Is there an alternative program I can use to restore a default Apple ipsw and jailbreak cleanly through redsn0w? Any other ideas as to what might be up with my MMS? Any advice on a procedure to correctly update/shift-restore without 16xxs or 29s? I have used iREB to get pwndDFU mode running but it never helps. The only thing that gets past 16xx for me (and subsequently into 29) is task manager/kill itunes.exe, then reopen and shift-restore again.

    I'm running on Windows XP, latest iTunes, and I have a buttload of ipsw's and SHSH's through tinyumbrella.

    Sorry for being so lengthy...but I wrote a tl;dr summary so there :P

    Thanks for any help!

    Kyle
    06-23-2011 08:12 PM
  2. kylezo's Avatar
    Bump...at this point I'm waiting for a phone number to the criminals who put a **** battery in this unit. Beyond that, I'm basically just praying that a clean restore and JB will clear up the MMS issue...
    06-29-2011 05:09 PM
  3. Peligro911's Avatar
    Bump...at this point I'm waiting for a phone number to the criminals who put a **** battery in this unit. Beyond that, I'm basically just praying that a clean restore and JB will clear up the MMS issue...
    Try updating to 4.3.3 but use snowbreeze so it won't update your baseband unless your never needing to unlock it
    Use snowbreeze to make custom Ipsw then with iTunes closed use red snow to put in dfu mode
    Once complete then open iTunes and do shift restore not upgrade and select your custom Ipsw
    06-30-2011 01:54 AM
  4. kylezo's Avatar
    Try updating to 4.3.3 but use snowbreeze so it won't update your baseband unless your never needing to unlock it
    Use snowbreeze to make custom Ipsw then with iTunes closed use red snow to put in dfu mode
    Once complete then open iTunes and do shift restore not upgrade and select your custom Ipsw
    Hey Peligro! I kind of ran right over this in my post, but I tried using snowbreeze with a custom 4.3.3 ipsw but it ran me into 29/16xx. Thanks for the suggestion, though!
    07-01-2011 03:12 AM
  5. Peligro911's Avatar
    Hey Peligro! I kind of ran right over this in my post, but I tried using snowbreeze with a custom 4.3.3 ipsw but it ran me into 29/16xx. Thanks for the suggestion, though!
    Use redsnow to put in to dfu mode for some reason redsnow makes it work vs other programs putting in dfu mode
    07-01-2011 03:28 AM
  6. kylezo's Avatar
    Use redsnow to put in to dfu mode for some reason redsnow makes it work vs other programs putting in dfu mode
    I used iREB and redsnow to get into DFU for the many attempts I made...they all errored out greenpois0n was the only thing that was able to get the phone into a working state again.
    07-01-2011 04:00 AM
  7. Peligro911's Avatar
    I used iREB and redsnow to get into DFU for the many attempts I made...they all errored out greenpois0n was the only thing that was able to get the phone into a working state again.
    Try downloading a already made custom Ipsw see if that works
    07-01-2011 05:52 PM
LINK TO POST COPIED TO CLIPBOARD