1. mededitor's Avatar
    I think I've read about this before, but I can't find anything in Search.

    I seem to have the new mail icon "stuck" in my status bar. I have no new messages and have cleaned out every folder in my mail application. I did a hard reset and several resprings. I have turned the mail notification on and off in LockScreen, I even reinstalled LockScreen. I sent myself an e-mail and deleted it.

    The mail icon in my dock doesn't have a badge showing any new mail, it's just the status-bar icon. I attached a picture showing my dilemma.

    I'm almost positive that it just started today; I don't think that I made any changes that should/would affect the status-bar icons. I downloaded Bolt from Cydia earlier today, but I don't remember if the mail icon was a problem before that download. I uninstalled Bolt, but that didn't make any difference. The mail icon is the only one that is acting up, SMS and missed calls aren't showing.

    I also noticed that when I open my mail Inbox, there is now a bar just under the main Inbox bar that reads "Search Inbox." I've never noticed that before and I don't know if that's related. A picture of that is also attached. I'd like to get rid of it, but I can't figure that out either.

    This is making me absolutely crazy. Any suggestions/help would be greatly appreciated.
    05-22-2011 11:32 PM
  2. grunt0300's Avatar
    Check and see if it is a notification of some kind, possibly through BiteSMS or Lockinfo if you have it.
    mededitor likes this.
    05-22-2011 11:43 PM
  3. mededitor's Avatar
    grunt, you're a GENIUS!!!!

    I have LockInfo, but I had mail notifications turned off for the Lockscreen, Homescreen, and Infoshade; I only wanted the e-mail icon on the status bar.

    I followed your advice and turned on the e-mail notification for my Lockscreen and voile, there were 6 messages that seemed to be stuck in limbo. I opened each one---although they seemed to be stuck in "download" mode---and deleted each one.

    The status bar icon is now gone. I don't know what happened or how it happened, but after hours of making myself crazy you solved the problem in minutes. With everything I tried, I never thought to turn on the LockInfo Lockscreen notifications.

    Thank you so much!
    05-22-2011 11:56 PM
  4. grunt0300's Avatar
    Thanks, but i'm no genius. I've gotten more help from this website than i care to think about. However, i do know all about Lockinfo.
    05-23-2011 12:37 AM
  5. mededitor's Avatar
    We're all geniuses in our own ways---at least that's what I'm choosing to believe. Collectively, this group can solve just about any problem known to a JB iPhone.

    Thanks again.
    05-23-2011 12:47 AM
  6. grunt0300's Avatar
    +1 for that. An excellent bunch of knowledgeable people use this website.
    05-23-2011 09:32 AM
LINK TO POST COPIED TO CLIPBOARD