1. Broseidon's Avatar
    1. I can't open OpenSSH, when I do it opens for half a second a closes.
    2. I can't connect through my computer to my phone using OpenSSH, I've been using Terminal and Cyberduck
    I have an iphone on 4.1 that i jailbroke with limera1n
    Please Please help
    05-15-2011 05:38 PM
  2. Gunn Ray's Avatar
    Have you ever were able to ssh into your iphone before?
    If not, you have to install a tool that allows to turn off or on the ssh. By default ssh is disabled for security reason.

    However, on my devices after 8 months or so I can't ssh into my iphone. I.e. it worked before, but it suddenly stopped. Of course I didn't update iOS or Cydia during those 8 monthes. So there is some problem really.
    05-17-2011 04:53 AM
  3. Ipheuria's Avatar
    You don't need to run OpenSSH on the phone just install it. Like Gunn Ray said you need SBSettings in order to turn OpenSSH on and off. So install that once it's installed swipe accross the top bar that has the time, battery life, etc. You will see a screen drop down and SSH should be there in red. You tap it and it turns to Green and it is on. Your phone must also be connected to a Wifi location so that you can get into it via it's IP. Whenever you use remember to turn it off it drains the battery like nobody's business.

    Once you get it working check out this thread Jailbreak and unlock the iPhone - Installing OpenSSH, using Fugu, shutting off the service, and changing the root and mobile passwords on how to change the passwords and get into your phone.
    Gigi100557 likes this.
    05-17-2011 12:44 PM
  4. Broseidon's Avatar
    Ok I got it to work last time. But then I restored and updated and stuff, thank you for the help though. Now I have a new problem. I'm running firmware 4.3.3 and OpenSSH wouldn't even show up on my springboard. I tried to SSH into it from my laptop and it gave me this error message:

    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @@@@@@@@@
    @ WARNING: REMOTE HOST IDENTIFICATION HAS CHANGED! @
    @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ @@@@@@@@@
    IT IS POSSIBLE THAT SOMEONE IS DOING SOMETHING NASTY!
    Someone could be eavesdropping on you right now (man-in-the-middle attack)!
    It is also possible that the RSA host key has just been changed.
    The fingerprint for the RSA key sent by the remote host is
    3e:12:08:63:33:55:2b:83:66:f0:1a:ae:23:65:62:ce.
    Please contact your system administrator.
    Add correct host key in /Users/ryan/.ssh/known_hosts to get rid of this message.
    Offending key in /Users/ryan/.ssh/known_hosts:1
    RSA host key for 192.168.1.77 has changed and you have requested strict checking

    I have a strange feeling i'm screwed
    05-17-2011 11:44 PM
  5. Massie's Avatar
    05-18-2011 01:08 AM
  6. Ipheuria's Avatar
    When did you get that message? trying to change your passwd? I get something like that and usually once I enable SSH and go in the first time using the default password with The FTP client. I then can SSH in and switch the passwd.
    05-18-2011 07:11 AM
  7. Broseidon's Avatar
    I got that message after I restored and rejailbroke. I installed OpenSSH and then I opened Winscp on my PC and it couldn't connect so I just went to my mac because I already had terminal open and thats how I did it last time. When I entered ssh root@<ip> it gave me that message
    05-19-2011 09:02 PM
LINK TO POST COPIED TO CLIPBOARD