1. mxracer84's Avatar
    I am trying to unlock my iphone 4

    I am running 4.3.3
    I jailbroke successfully with redsnow (unteetherd)

    I put the original sim card I got with the phone into the phone (Carrier locked to rogers here in canada)
    and it says you have a voicemail then shows no service,

    I put my telus sim card into the phone (the one I would like to use once the phone is unlocked) and it shows no service

    This phone seems to constantly show no service , how do I unlock it so it will take any sim card, I have tryed to restore it through apple so I could put the old rogers sim card in and that does not work either it still shows no service.

    I have tryed repo666.ultrasnow.com in cydia and this keeps giving me 3 error messages and saying it cant fetch data or somethingg

    All help would be greatly appreciated , I would really like to get my iphone 4 working so I can start using it .

    Thanks in advance,

    James
    05-13-2011 11:38 AM
  2. vietalogy's Avatar
    Whats your baseband?
    05-13-2011 12:21 PM
  3. myzhi's Avatar
    To OP, I am going to guess that you updated your baseband with 4.3.3 firmware which means you can't use Ultrasnow to unlock. In fact, Ultrasnow hasn't been updated since 1.59 baseband (4.0.2 firmware). If you are waiting for an update, you are going to wait for a every long time.

    You only option is trying the Gevey Turbo Sim (google).
    05-13-2011 01:11 PM
  4. mxracer84's Avatar
    Hi guys thanks for the fast replies,

    I am running baseband : 04.10.01
    firmware 4.3.3 (8J2)
    Model : MC603C

    Also regardless of the baseband shouldnt my rogers sim card work regardless of the unlock , because that what the phone is carrier locked to , Still the rogers shows "no service"
    05-13-2011 01:34 PM
  5. myzhi's Avatar
    Hi guys thanks for the fast replies,

    I am running baseband : 04.10.01
    firmware 4.3.3 (8J2)
    Model : MC603C

    Also regardless of the baseband shouldnt my rogers sim card work regardless of the unlock , because that what the phone is carrier locked to , Still the rogers shows "no service"
    Restore to official 4.3.3 firmware and see if your Roger sim works. If not, there's something wrong with phone or sim card / service with Roger. If it works, re-JB. Don't try installing Ultrasnow since it won't work.
    05-13-2011 02:47 PM
  6. Ipheuria's Avatar
    Stop trying things you think will work and do it only when you've researched it. It is a quick way to screw up your phone. I would just hook up to iTunes and hit restore this will reload the firmware from scratch. You can't unlock the phone so don't re-JB put your SIM in and see if you can get the Rogers network. If it doesn't work take the phone back if it does then Redo the JB and you should be good to go.
    05-13-2011 03:36 PM
LINK TO POST COPIED TO CLIPBOARD