1. nightcrawler's Avatar
    Okay, so I had one custom text tone on iOS 4.1. Yesterday I upgraded to 4.2.1 and jailbroke my iphone 4 (at&t) and reloaded the text tone though diskaid. I also created and trimmed three more text tones in iTunes and transferred them to my iphone using diskaid as well.

    The tones show up in my phone and play normally in 'Sounds' when I test them. However, when I actually get a text tone it doesn't play the entire clip. Each tone is about 3 seconds long.

    Findings so far: I'm using Tlert, shut it off-no effect. I also went into Winterboard (where my tones are) unchecked my tones and resprung. Went back into Winterboard, recked my text tones, resprung. This seemed to help a little. Sometimes it plays the majority of my tone, other times it only plays about half.

    Has anyone had this issue or have any ideas to fix it?

    Thanks!
    04-16-2011 10:34 PM
  2. Ipheuria's Avatar
    I'm just wondering why your tones are in Winterboard? The two ways I know of to use tones for texts is either to change the original tones so even though you choose the original theme it plays your custom tone. The other way is to do it via Bite SMS and that is an awesome way to do it plus it's a wicked app. So I'm just wondering why yours goes through Winterboard?
    nightcrawler likes this.
    04-17-2011 01:57 AM
  3. Massie's Avatar
    Using WB is a pretty standard method for theming sounds. (Look in Cydia for SMS tones and you'll find most are WB themes.)

    I just do direct replacements, myself, but for someone who might want a large library of sounds available at all times, WB makes sense.
    04-17-2011 02:01 AM
  4. Ipheuria's Avatar
    Ahhhhhh ok never knew of this method. Ya learn something new every day.
    04-17-2011 02:04 AM
  5. nightcrawler's Avatar
    Using WB is a pretty standard method for theming sounds. (Look in Cydia for SMS tones and you'll find most are WB themes.)

    I just do direct replacements, myself, but for someone who might want a large library of sounds available at all times, WB makes sense.
    Which method do you use for the direct replacements for the sms tones?
    04-17-2011 02:28 AM
  6. BLiNK's Avatar
    just google "change SMS tones iPhone" and you will find a large amount of information

    or start here, a lot of good info:

    http://forum.tipb.com/jailbreak-unlo...ail-tones.html
    04-17-2011 10:59 AM
  7. Ipheuria's Avatar
    You could also take the easy route and just use BiteSMS too. It's Trial, then you can either pay for it or use it ad supported.
    04-17-2011 12:03 PM
  8. nightcrawler's Avatar
    I could use BiteSMS, but when I have an issue I get determined to fix it.

    Okay, so I removed the SMS tones out of winterboard and loaded them through DiskAid. I wasn't asking how, I was just curious what method you used. I used DiskAid again, but there's more than one way.
    I still have the same problem. Hmm...when I have time I might try editing the tones in iTunes again and start the process over and see if that does anything.
    04-17-2011 12:29 PM
  9. nightcrawler's Avatar
    PS:
    I have my doubts because the tones still play full length in 'Sounds,' but it's worth a shot. Oh, and I also rebooted the phone after removing the tones from Winterboard and loading them directly on the phone.
    04-17-2011 12:33 PM
  10. Ipheuria's Avatar
    Instead of creating the tones try getting a pre-made tone. You can get them on Free Ringtones for mobile and iPhone - Audiko and see if you have the prob? If you don't then it has something to do with how your tones are being made.
    04-18-2011 12:51 AM
  11. BLiNK's Avatar
    i like to use tones from other apps, which are already .caf files or go to Zedge and convert them to .caf
    04-18-2011 01:04 AM
LINK TO POST COPIED TO CLIPBOARD