1. talkin73's Avatar
    I am getting the attached error message anytime I go to a Cydia screen other than the main screen (such as Changes or Manage) that shows when you launch the app. It forces the screen to reload and then I have to "Return to Cydia" at which point the data reloads again and all seems okay. It's been happening consistently the past 3 days.

    What is this error message and is there a way to fix whatever isn't working so it goes away? Thanks for any feedback!
    04-11-2011 08:21 PM
  2. iRandom's Avatar
    It means that Cydia isn't able to get the files from the sources.

    The only way to fix it is to wait until the sources are back up and running.
    04-11-2011 08:38 PM
  3. talkin73's Avatar
    It means that Cydia isn't able to get the files from the sources.

    The only way to fix it is to wait until the sources are back up and running.
    Thanks. I've received error messages before but none that continued unchanged for days at a time... maybe minutes or hours but eventually resolved. I assumed it was something temporary but it has lasted so long. Do you get these same messages when loading the Cydia pages I mentioned?
    04-11-2011 09:52 PM
  4. iRandom's Avatar
    I haven't noticed anything on mine. :/
    04-12-2011 06:55 AM
  5. Massie's Avatar
    If you keep having problems, take a look at this article: Troubleshooting Cydia: Problems with Broken Repos
    04-12-2011 07:17 AM
  6. talkin73's Avatar
    If you keep having problems, take a look at this article: Troubleshooting Cydia: Problems with Broken Repos
    Thanks for pointing me to this link. Looks like I have old/broken repos that were probably restored by Pkgbackup on my last JB. The problem is that I also have the new/correct ones as well. When you try to edit the list of repos as suggested by the article and in the comments area, the only ones that can NOT be deleted are the broken ones There is no minus sign that appears to delete them or even after a left swipe. I can't find them anywhere using iFile and they are NOT in the folder suggested by the article when viewing with iFile. In fact, even the author's screenshot shows only 2 repos and I'm guessing those two are the current ones given the dates of these files on my iP4. Any other suggestions on getting rid of these old repos?
    04-12-2011 08:00 AM
  7. Pocobear's Avatar
    I have the exact same problem as Talkin73, and like Talkin73, I can't find these entries with iFile or iPhone explorer. Where should we look to delete these dead links?
    04-12-2011 08:12 AM
  8. Ipheuria's Avatar
    You can also try clearing the que. I had a problem once where an app just wouldn't install it said it couldn't find the repo. I tried after a couple of hours and still the same problem. I finally cleared the que and the app installed no problem. So I think sometimes for some reason maybe if the repo had a problem and made a change the app in the que is still looking in the old location for the files.
    04-12-2011 11:11 AM
  9. Pocobear's Avatar
    FOUND ANSWER!! Yay, the author of PkgBackup, Jibril Gueye, sent me the instructions for curing this problem.

    With Cydia not running, use your favorite file browser such as iFile, and navigate to here;
    /var/lib/cydia/metadata.plist and delete the metadata.plist file.

    Restart Cydia and let it update (rebuild the plist). It will install all the standard sources, if you need any other sources, you may need to install them manually.

    This worked fine for me on my iPad.
    talkin73 likes this.
    04-12-2011 01:51 PM
  10. talkin73's Avatar
    FOUND ANSWER!! Yay, the author of PkgBackup, Jibril Gueye, sent me the instructions for curing this problem.

    With Cydia not running, use your favorite file browser such as iFile, and navigate to here;
    /var/lib/cydia/metadata.plist and delete the metadata.plist file.

    Restart Cydia and let it update (rebuild the plist). It will install all the standard sources, if you need any other sources, you may need to install them manually.

    This worked fine for me on my iPad.
    Pocobear, thanks for posting this. I got a reply from the author last week but it involved using a tutorial he sent me a link to read through. Sounds like he found a faster fix. Much appreciate you sharing, this fixed my problem as well!
    04-16-2011 04:12 PM
LINK TO POST COPIED TO CLIPBOARD