1. CHAM89's Avatar
    Hey everyone, every time I go and open Cydia for the past week or so I get this error screen that says exactly:

    "! GPG error: //cydia/hacklo.us ./Release: The following signatures were invalid: NODATA 1 NODATA2

    ! Failed to fetch //cydia.hacklo.us/./Packages.bz2 Sub-process /bin/bzip2 returned an error code (2)

    X Some index files failed to download, they have been ignored, or old ones used instead"


    Ive had my phone jailbroken for about a month and have only been getting this screen for about a week, anyone know the cause/how to fix it? I have a screen shot of the error screen but cant post the link to the picture cause of my post count, any help would be appreciated.
    03-28-2011 11:33 PM
  2. Fausty82's Avatar
    Are you running Cydia 1.0 or 1.1?

    It may be a problem with the repo... have you tried removing it (the hackulo.us repo) and re-adding it?
    03-28-2011 11:40 PM
  3. CHAM89's Avatar
    running cydia 1.1, didnt think to try removing and re-adding the repo, I'll give that a shot
    03-28-2011 11:43 PM
  4. Fausty82's Avatar
    Did you do the update to 1.1 in the "past week or so"? Maybe it's related to the upgrade... I had one repo that got hosed... just removed it and re-added it. Give it a shot and let us know how that works...
    CHAM89 likes this.
    03-28-2011 11:47 PM
  5. CHAM89's Avatar
    yea the upgrade to 1.1 was around the same time this error started. I removed and re-added the repo, seems to be working havent received that error message yet. Thanks!
    03-28-2011 11:52 PM
  6. Fausty82's Avatar
    glad to hear it!
    03-29-2011 12:03 AM
  7. CHAM89's Avatar
    spoke too soon, just went into cydia again and got the same error. It appears every time cydia is refreshing the info that pops up above the cydia title bar when first opening cydia
    03-29-2011 12:17 AM
  8. JohnH59's Avatar
    I'm getting the same error, but with a different repo. I messed up when I upgraded Cydia and tapped 'Essentials' instead of 'Complete". I figured that was why. I'm still able to update apps and install new ones without any problems. It just takes a little longer to load and I get the 'NODATA' error.
    03-29-2011 12:50 AM
  9. CHAM89's Avatar
    I think I may have done the same thing, and clicked esssentials instead of complete when upgrading to 1.1, is there a way to re-install 1.1?
    03-29-2011 12:57 AM
  10. Fausty82's Avatar
    There could be an issue with 1.1... here's a report of similar problems, but with a different repo:

    http://forum.tipb.com/jailbreak-unlo...azio-repo.html
    03-29-2011 09:51 AM
  11. JohnH59's Avatar
    I think it's because of tapping Essentials instead of Complete. I've upgraded my iPad tapping on Complete and I don't have any errors when I launch Cydia. Luckily, I can't find anything not working. Just getting the repo errors.
    03-29-2011 12:10 PM
  12. CHAM89's Avatar
    Is there a way I can re-install cydia 1.1 so that I can click the 'complete' option?
    03-29-2011 03:17 PM
LINK TO POST COPIED TO CLIPBOARD