1. kingweb's Avatar
    I see that it is indeed possible to unlock with 4.2.1 and baseband 1.59?
    How to Update to iOS 4.2.1 and Preserve iPhone 4 1.59.00 Baseband

    I remember reading that 4.2.1 checks to see if a newer baseband exists, so 1.59 won't work.
    So what's the deal will this work or not?
    02-07-2011 12:02 AM
  2. kingweb's Avatar
    Well, I was too impatient, so I tried it and it worked!
    02-07-2011 12:57 AM
  3. Ipheuria's Avatar
    Yes pwnage tool is out which enables you to JB 4.2 while preserving the baseband to allow you to unlock.
    02-07-2011 02:26 PM
  4. kingweb's Avatar
    Well, I did it and it worked, but I still recall reading somewhere that 4.2.1 checks to make sure that it is using the correct baseband, and 1.59 is not.
    Was that baseband check disabled by the jailbreak?
    02-07-2011 02:30 PM
  5. kingweb's Avatar
    02-07-2011 02:32 PM
LINK TO POST COPIED TO CLIPBOARD