1. mmjax's Avatar
    Hi all.

    I'm sorry if this is a very newbie-ish question, but I have to say I am completely overwhelmed with the amount of information on jailbreaking that is available out there. I am having a hard time sorting through what applies to me, and what doesn't.

    My 3GS is running 3.1.3(7E18), firmware 05.12.01. It has never been jailbroken, and I bought it the first week that the 3GS's came out.

    I do not have access to a Mac, so my solution has to be windows-based.

    My goal is to have my phone running some version of 4.x, and be jailbroken and unlocked. I would like to be able to power-cycle the phone and not have to re-jailbreak (I think that's non-tethered, right?). I'm on AT&T but at some point soon I will sell the phone so I want it to be unlocked to broaden the potential market.

    Can one of you experts help me out and tell me what steps I need to take to go from my version to a jailbroken 4.x version? What software do I need, and do I need to upgrade to 4.x first, or jailbreak then upgrade?

    Thanks in advance for anyones help.

    -M-
    Last edited by mmjax; 01-25-2011 at 12:28 PM. Reason: incomplete posting
    01-21-2011 11:18 AM
  2. iRandom's Avatar
    Until an untethereed solution comes out, here's what I've got:

    • Download the iOS 4.1 IPSW for your iPhone 3Gs
    • In iTunes, Shift + Click "Upgrade"
    • Browse for the 4.1 IPSW and click "Open"
    • Wait for the upgrade process to finish
    • Use Greenpois0n to jailbreak your device (this is untethered)
    • Go to Cydia and search for Ultrasn0w to unlock
    • Viola!


    STAY AWAY FROM 4.2.1
    01-22-2011 01:24 PM
  3. mmjax's Avatar
    Over the weekend I tried to follow your suggestions.

    I downloaded IPSW 4.1, then shift+Click Update and browsed to the file. It sat on "Verifying update with Apple" (or something like that), then eventually came back and gave me an error message 3194. I tried 3 or 4 times with the same result.

    Any idea what I am doing wrong here?

    Also do I need to save "blobs" or anything else before doing the upgrade?

    Thanks in advance...

    - M -
    01-25-2011 12:20 PM
  4. mmjax's Avatar
    No thoughts anyone?
    01-27-2011 09:40 AM
  5. jackie treehorn's Avatar
    Yes you needed blobs for 4.1(which I'm almost certain that Apple is no longer signing) to be able to update to that since 4.2.1 is the most current. Without those I believe you are stuck with 3.1.3 or update to the newest 4.2.1
    01-27-2011 11:59 AM
LINK TO POST COPIED TO CLIPBOARD