1. mdpatsfan's Avatar
    To start I have an Iphone4 running 4.2.1 with Redsn0w jailbreak. Jailbreak apps include SB settings, bite SMS, Call lock, 5 Icon Dock, Lock Info, SB Rotator, Spring Flash, MyWi, Cydelete, and My 3G. Thinks thats it. My issue is apps are missing on my phone that are showing installed in itunes. If I do a search on my iphone it finds it and I can launch the missing app. Also in itunes when I go to my devices then apps the apps loaded on my phone do not show in folders I have made. It just shows all my apps out of the folders. If I try to move or make new folders in itunes they will not sync to my phone and move back out of the folders in itunes. So in other words my phone does not match what shows under my devices in the apps section in Itunes. I have tried to remove all of my apps under my devices then apps and reinstall them but they went right back to how it was before I removed them. Hope you understand what I am asking. I have attached a screen shot of my first home screen in itunes and on my phone. Any ideas how to fix my issue short of restore? Thanks for looking.
    Attachment 7677

    Attachment 7678
    01-03-2011 12:22 AM
  2. jdavis530's Avatar
    Have you tried rebooting the phone?
    01-03-2011 06:36 PM
  3. mdpatsfan's Avatar
    Yes I have.
    01-03-2011 07:20 PM
  4. myzhi's Avatar
    I have read of that this problem. It relates to using infinite dock, infinite folders and/or something similar. Do you have something like this installed?
    01-03-2011 09:31 PM
  5. porksoda's Avatar
    if your problem is apps are on the phone but they dont have an icon... do this:

    go to sbssettings... go to more... hide icons... make sure the apps whose icons are missing is not OFF just to be safe set all icons to ON.
    mdpatsfan likes this.
    01-05-2011 07:26 PM
  6. Ipheuria's Avatar
    What about the 5 icon dock? The iTunes doesn't match up with the dock ofcourse would that cause a problem? I've heard of this before, do a search for missing apps or something and post up if you fix the problem.
    01-08-2011 01:18 AM
  7. mdpatsfan's Avatar
    Thank you porksoda. The problem was two fold, first porksoda figured out my missing app. Not sure how I managed to hide those apps but I did. The other fix to my issue was SB rotator. Once I uninstalled and restart my phone it worked as normal on itunes. Thank you for all the response.
    01-08-2011 09:13 PM
  8. porksoda's Avatar
    Thank you porksoda. The problem was two fold, first porksoda figured out my missing app. Not sure how I managed to hide those apps but I did. The other fix to my issue was SB rotator. Once I uninstalled and restart my phone it worked as normal on itunes. Thank you for all the response.
    no probs... i had some app/util that i installed and it Hid some icons... i forgot which app/util.
    01-08-2011 10:11 PM
LINK TO POST COPIED TO CLIPBOARD