1. RedDevil#IM's Avatar
    Please advise. Running 3G with IOS 4.2.1 & Redsnow JB, everything was working perfectly. I installed the new Cydia update, now whenever I click on a link in my emails so that I can view it in Safari my phone resprings to safe mode and then does another automatic respring and returns to the home springboard. Btw, Cydia's running perfectly though. Please help cause I'm really not in the mood to redo my entire phone AGAIN.
    12-04-2010 11:12 AM
  2. myzhi's Avatar
    It's probably an app or tweak you install from Cydia that is causing the problem. Start uninstalling stuff and test.
    12-04-2010 12:21 PM
  3. RedDevil#IM's Avatar
    Thank you for replying, you were right. I identified the problem by illimination and it turned out to be my "multitasking function". I Googled a fix and got it. Ran the fix and I'm good to go. Thanks again.

    Here's what I found:

    "Credit goes to an Unregistered user, GuitarMan0121. Thanks bro!

    As some of you may know, Apple borked multitasking for older devices just to be mean to us. Well we finally figured out how to make it work.

    DO NOT use redsn0w to enable multitasking.. Do it manually, it has some issues and will screw with your device otherwise.
    iPhone 3G = N82AP
    iPod touch 2G = N72AP

    What You'll Need
    A jailbroken iDevice on 4.2.1(Orlly?)
    Plist editor(iFile or whatever you have)
    SSH

    Let's Get To It!

    Alright, open up WinSCP or iFile, and Navigate to /System/Library/CoreServices/Springboard.app and open up either N82AP or N72AP.plist.

    Make sure Multitasking is enabled, if you don't see
    multitasking

    Then add it.

    Find the section that says
    opengles-1

    And change the 1 to a 2. Respring and there you go."
    BLiNK likes this.
    12-04-2010 04:07 PM
  4. c0rinne's Avatar
    Hey RedDevil, thanks for the info! I knew it was multi-tasking (because it always crashed whenever I double-clicked and selected to open another app) but I couldn't find a way to fix.

    I had installed zToggle (via Cydia) to disable multi-tasking, but I took the risk, disabled zToggle and followed those steps and now it works.

    I still think my iPhone is slower with multi-tasking on, but I'll try it out for a couple days to see what I prefer. I was just getting used to having it turned off, lol.
    12-04-2010 06:14 PM
  5. BLiNK's Avatar
    nice fix, thanks!

    so far everything seems to run good on my 3G with multitasking enabled when before it was crashing the spring board right away
    12-04-2010 07:19 PM
  6. c0rinne's Avatar
    Anyone else experiencing lines in buttons with multi-tasking turned on?

    See here: Cloud2go Dec 5, 2010 6:54 PM.jpg

    Looking at the Send Button. there's a white line. It goes away when I turn multi-tasking off. I can't seem to get rid of it any other way.


    ETA: Looks like I'm not the only one: [HowTo] Fix Multitasking on Older devices! - iPod touch Fans forum - iPod, iPhone and iPad
    Last edited by corinne; 12-05-2010 at 10:14 PM.
    12-05-2010 10:11 PM
  7. BLiNK's Avatar
    Anyone else experiencing lines in buttons with multi-tasking turned on?

    See here: Cloud2go Dec 5, 2010 6:54 PM.jpg

    Looking at the Send Button. there's a white line. It goes away when I turn multi-tasking off. I can't seem to get rid of it any other way.
    yes, this is very annoying and after reading about this, it does not look like it's going to be fixed or worth the trouble for someone to fix it
    12-06-2010 01:30 PM
  8. Capnjackk's Avatar
    psssst; there's a reason why the 3G wasn't given multi-tasking to begin with.
    12-07-2010 03:39 PM
  9. c0rinne's Avatar
    So. I decided to use ztoggle to turn off multitasking and just then use multiflow and backgrounder to multitask.

    That way I can avoid all those annoying problems and control which apps stay open in the background.
    12-16-2010 09:32 PM
LINK TO POST COPIED TO CLIPBOARD