1. dcraig7's Avatar
    I have an iPhone 3G on software 3.1.3 jailbroken using Spirit and unlocked using UltraSnow for TMobile. I downloaded TinyUmbrella hoping to save my 3.1.3 shsh but wasn't able to. I was able to somehow save 4.0 shsh. I have the baseband of 5.12.01. If I upgrade to 4.0 using Tiny Umbrella. Will I still be able to jailbreak and unlock it. It's important because I need to be able to use TMobile. Just wondering if this was possible since I've been hearing that if you upgrade your baseband you wont be able to unlock. Thanks.
    10-10-2010 11:33 AM
  2. dcraig7's Avatar
    Ok so anybody out there that can help me?
    10-11-2010 10:08 AM
  3. myzhi's Avatar
    Yes. As long as you don't upgrade to 4.1 => 5.14 baseband, you can JB & unlock.
    dcraig7 likes this.
    10-11-2010 12:02 PM
  4. dcraig7's Avatar
    Still kind of nervous of not being able to unlock my iphone. So it doesnt matter what bootload i have either?
    10-11-2010 02:11 PM
  5. dcraig7's Avatar
    And if I want to downgrade to 3.1.3 will I still be able to do that and unlock it?
    10-11-2010 02:51 PM
  6. farbod21's Avatar
    You guys, once you upgrade BB firmware you CANNOT downgrade it. Only OS firmware can be downgraded.

    The only BB workaround using TU I can confirm is on the iPhone4. You should check im semaphore for any other upgrades...
    10-11-2010 04:22 PM
  7. swooshme's Avatar
    You guys, once you upgrade BB firmware you CANNOT downgrade it. Only OS firmware can be downgraded.

    The only BB workaround using TU I can confirm is on the iPhone4. You should check im semaphore for any other upgrades...
    ^^ What he said.
    I just upgraded my iPhone 4 to 4.1 using Tiny Umbrella to preserve my baseband and I did extensive internet search on the topic before I did. You'd be surprised at how many people DO NOT READ INSTRUCTIONS before doing stuff to their phone. It says all over the web that the current version of Tiny Umbrella doesn't work for 3G and 3GS to preserve baseband, yet people get perplexed about why they lost their unlock or why their baseband got updated.

    I did a couple hours worth of research and I don't even need the unlock, but I wanted to keep my pre 4.1 baseband just in case.
    farbod21 likes this.
    10-11-2010 04:29 PM
  8. farbod21's Avatar
    ^^ What he said.
    I just upgraded my iPhone 4 to 4.1 using Tiny Umbrella to preserve my baseband and I did extensive internet search on the topic before I did. You'd be surprised at how many people DO NOT READ INSTRUCTIONS before doing stuff to their phone. It says all over the web that the current version of Tiny Umbrella doesn't work for 3G and 3GS to preserve baseband, yet people get perplexed about why they lost their unlock or why their baseband got updated.

    I did a couple hours worth of research and I don't even need the unlock, but I wanted to keep my pre 4.1 baseband just in case.
    X1000

    Excellent post. Thanks for the info.
    10-11-2010 04:47 PM
  9. myzhi's Avatar
    And if I want to downgrade to 3.1.3 will I still be able to do that and unlock it?
    Do not update to 4.1 because the baseband can't be unlock.

    Unlike 3GS and IP4, Apple uses a software SHSH check on Iphone 3G. It's pretty easy to get around. And, yes, should be able to restore to 3.1.3.
    Last edited by myzhi; 10-11-2010 at 07:52 PM.
    10-11-2010 05:48 PM
  10. swooshme's Avatar
    Just a tip. I updated 2 iPhone 4s today using tiny umbrella to preserved baseband and on both of them the kick out of recovery didnt work. I was using the latest version of TU 4.1.6. I ended up downloading 4.1.5 and then clicked kick out of recovery and it worked fine. Now both phone are set jailbroken with limera1n, iOS 4.1, and preserved baseband.
    10-11-2010 07:31 PM
  11. myzhi's Avatar
    Just a tip. I updated 2 iPhone 4s today using tiny umbrella to preserved baseband and on both of them the kick out of recovery didnt work. I was using the latest version of TU 4.1.6. I ended up downloading 4.1.5 and then clicked kick out of recovery and it worked fine. Now both phone are set jailbroken with limera1n, iOS 4.1, and preserved baseband.
    That only works on IP4.
    10-11-2010 07:52 PM
LINK TO POST COPIED TO CLIPBOARD