1. slumcat's Avatar
    Before jailbreaking, my iPhone would automatically popup a login page whenever I joined a wifi network that used a capture portal, such as in a hotel. At some point this stopped working. I can't pinpoint whether it was after I did a specific jailbreak or after installing a particular package, but it's now impossible to use hotspots with capture portals.

    I don't get any error message, the wifi connection is successful and I get an IP address, subnet, DNS, etc. from the hotspot, but there's no popup for the login page, nor does it come up when I launch Safari. Instead, Safari (or any other app) continues to happily use my 3G or EDGE connection, if available. I tried disabling the 3G using SBSettings toggles to try and force wifi use, but I end up getting a message about no internet connection available.

    In doing some research on this issue, I found some screens that discussed the auto-login feature that was added in 3.0 (phone was preloaded with 3.1), and also shows some screenshots of the wifi settings page with a toggle for "Auto-Join" (I can't post links or photos, but it was on this site with the tag "auto-login"), my phone does not have this toggle on any wifi networks.

    I have an iPhone 3GS running 4.0 jailbroken with sn0wbreeze.

    I've searched for every term I could think of for this on this site and web-wide and haven't been able to find anyone else with this problem, so I apologize if this has already been answered somewhere else.
    09-24-2010 12:47 AM
  2. slumcat's Avatar
    I've also found that I have trouble logging in to attwifi hotspots. I have an AT&T data account, so I should be able to get free AT&T wifi. I can connect to the hotspot, and this time I actually get the wifi connection icon in the statusbar, but when I open Safari it takes me to the standard AT&T gateway asking me to pay or login with a wifi account (instead of the expected iPhone portal that asks for your mobile number). Any thought?
    09-30-2010 12:47 PM
  3. Slyfi's Avatar
    The auto-login was added but doesn't do much on my phone you go Settings>>WiFi>>tap the blue button to the left of the WiFi your trying to join. its on that page towards the top
    09-30-2010 04:46 PM
  4. Reparkable's Avatar
    I'm having the same problem. My iPhone 4 says i'm connected to my home wifi router, but the 3G logo is still in the top left. I go to the speedtest app and it says i'm connected to 3G and not wifi. But in the settings it has the check mark beside the wifi network its connected to and my wifi is turned on. The router settings on my computer say i'm not connected....so i'm lost.
    10-07-2010 10:00 PM
  5. Reparkable's Avatar
    Ok, after doing some more digging I solved it. All I needed was a firmware upgrade to my router. Went to the Cisco website, downloaded the latest firmware for the E1000, and boom, fixed.
    10-08-2010 12:53 AM
LINK TO POST COPIED TO CLIPBOARD