1. Pipes's Avatar
    I bought my wife a brand new Iphone christmas 08 when the new 3gs came out paid the full price 800$ for it, so that down the road i could transfer to a different company and not have to worry about a Contract.

    Skip Ahead to this weekend we switch from Rogers to Bell and was told i had to get my phone unlocked to work with Bell, i brought it to two different places to get it unlocked. i Can make phone calls, i can connect to Wifi, i can sent text msgs just fine, but i can not connect to the data network. I have put my SIM card into a different phone with the Wifi off and worked just fine so i know its not the card.

    When i go to Settings: General: Network: i have 3G enabled but under that it says: Cellular Data network: with no "on" or "off" option, but rather a screen for entering APN username/password.

    Any suggestions i just tried using the Spirit App to get it work, no joy. i don't need extra themes or apps i just want to be able to connet to the Data network, and not have to rely on my WI/FI (which my office doesn't have).

    my phone info is: Version 3.1.3(7E18)
    Carrier 5.1
    Model: MC145c
    09-20-2010 12:49 AM
  2. ducky's Avatar
    maybe this will help, if all you need is apn settings. i have no experience with this, but bookmarked this when i was looking for international data network info

    Carrier APN Settings - ModMyi - Wiki
    Last edited by ducky; 09-20-2010 at 01:04 AM.
    Pipes likes this.
    09-20-2010 01:00 AM
  3. myzhi's Avatar
    09-20-2010 01:02 AM
  4. Pipes's Avatar
    thank you for the Idea's the APN info really helped i found this page:

    torontophonerepair.com/iphone-repair-a-unlocking/iphone-internet-setting.html
    Really made it Simple and it works, thank you for your help, was able to manually enter the settings...now my wife won't have to steal my new iphone 4.
    09-20-2010 01:49 AM
LINK TO POST COPIED TO CLIPBOARD