1. 1alonso's Avatar
    Hi,
    I have this Iphone 3G working on Tmobile and some other carriers overseas. I have an AT&T sim I try tu use but it shows no SIM detected.
    I have tried many other AT&T sim cardsa with same result. Even have tried Virgin and also does not work.

    Does anyone know how can I fix this? I appreciate any help... I have changed ffrom Tmobile to ATT and now I cant use my Iphone

    Thanks
    08-24-2010 11:39 AM
  2. TampaDude's Avatar
    You do realize that the 3G frequencies are totally different between AT&T and T-Mobile, right?
    08-24-2010 01:34 PM
  3. 1alonso's Avatar
    Thanks for your input... I have 4 cell phones that I switched from Tmobile to ATT. all were unlocked. All of them are used overseas also eventually.

    All of them are working now in ATT except for this Iphone... I have blackberry, prada . All of them had been using data on Tmobile and now are using data on ATT with no issues at all... blackberry and prada are using EDGE now instead of 3G because of you mention... Edge is a bit slower but cannot tell the difference... but i dont think this is the problem...
    08-24-2010 05:36 PM
  4. rdiddy_25's Avatar
    You do realize that the 3G frequencies are totally different between AT&T and T-Mobile, right?
    That only means that he wont have 3g speeds, only edge. Should still be able to make calls. Tty resetting ur network settings once u install ur att sim card. If that doesmt resolve the issue u may need to restore thru itunes and then downgrade to jailbreak again.
    08-24-2010 09:19 PM
  5. TampaDude's Avatar
    That only means that he wont have 3g speeds, only edge. Should still be able to make calls. Tty resetting ur network settings once u install ur att sim card. If that doesmt resolve the issue u may need to restore thru itunes and then downgrade to jailbreak again.
    Yeah...lack of 3G is a dealbreaker for me. I'm sticking with AT&T. If I wanted only EDGE, I could've just kept my Curve.
    08-25-2010 11:38 AM
  6. big9erfan's Avatar
    The OP is going FROM TMobile to AT&T with an iPhone that SHOULD support AT&T. I'm wondering if the iPhone 3G was reported stolen to AT&T and AT&T thus blocked it's IMEI.
    08-25-2010 11:44 AM
  7. TampaDude's Avatar
    The OP is going FROM TMobile to AT&T with an iPhone that SHOULD support AT&T. I'm wondering if the iPhone 3G was reported stolen to AT&T and AT&T thus blocked it's IMEI.
    UGH...BLACKLISTED!!!
    08-25-2010 11:47 AM
  8. 1alonso's Avatar
    Thanks to all for your input. The cell phone has not been reported as stolen ( I have had it since new)... but still the problem is that it wont read the AT&T sim... it never gets to AT&T network because when I use this sim it shows NO SIM... when I use Tmobile, and some other GSM SIMS outside US works as it should. ( china, south america, europe)

    So I guess I will restore using Itunes and the jailbrake again... hopefully I wont get it screwed... or any other suggestions?
    08-25-2010 03:29 PM
LINK TO POST COPIED TO CLIPBOARD