1. DucoNihilum's Avatar
    I'm using a 3GS that came with 3.1.3 (I assume new bootrom), I'd like to install 4.0 jailbroken. So far I've gotten to the point where I realize I might need 3.1.2, however, it's impossible for me to do so without SHSH, which I don't have because I've never used cydia on this device.

    Can I still jailbreak this? Is there a workaround?
    08-03-2010 05:27 PM
  2. peanutgallery's Avatar
    If you don't have the 3.1.2 shsh blobs you can't downgrade.

    You can upgrade to 4.0.1 and use the new jailbreak at jailbreakme.com
    08-03-2010 05:32 PM
  3. DucoNihilum's Avatar
    Will that work with the 3GS?
    08-03-2010 06:21 PM
  4. w00dy's Avatar
    Short answer: yes
    is it worth the risk (not at this time): no

    spirit jailbreak would be a better alternative for you
    08-03-2010 06:57 PM
  5. peanutgallery's Avatar
    Spirit would work to jailbreak his 3.1.3 but the OP wanted to jailbreak 4.0.1.

    So if you want a jailbroken 3.1.3 you can use spirit, so long as you are using iTunes 9.1. If you upgraded iTunes you'll need to find an old install file for 9.1.

    If you want a jailbroken 4.0 / 4.0.1 you'll need to use jailbreakme.com
    08-03-2010 07:56 PM
LINK TO POST COPIED TO CLIPBOARD