1. dood's Avatar
    Okay, I have a 3GS 3.1.2 with the new bootrom jailbroken with blackra1n (aka tethered). I am currently trying to restore, via the Restore button in iTunes, as well as the shift+restore with the 3.1.2 firmware. However, after the "Verifying iPhone restore with apple" screen, I get a "The iPhone "x" could not be restored. The iPhone is not eligible for this build." or 3014 error. Now, Cydia says that it has my 3.1.3 and 4.0 cache files for my device on cache. Will restoring via the shift+restore method with the 3.1.3 firmware brick my phone?
    08-02-2010 11:13 AM
  2. crystus's Avatar
    It should not brick your phone. The error you are receiving is because you do not have the 3.1.2 blobs on file therefore it can not verify the firmware to sign it.
    08-02-2010 12:50 PM
  3. rdiddy_25's Avatar
    Now that the 4.0 jb is out, just restore as new, then jailbreak. That's alot easier than restoring, downgrading to 3.1.3, then jailbreaking.
    Last edited by rdiddy_25; 08-02-2010 at 12:55 PM.
    08-02-2010 12:52 PM
  4. dood's Avatar
    Restore as new doesn't work :P Regardless, I've read a bunch of apps don't work on iOS4 yet, so I'm just gonna stick with 3.1.3 for now.
    08-02-2010 06:49 PM
LINK TO POST COPIED TO CLIPBOARD