1. CheeseToasty's Avatar
    Hi Guys,

    Posted this on a couple of other forums with no luck, thought I would try here before I accept defeat.

    Basically Jailbroke my iPhone 3GS 3.1.3 (New Bootrom) with Spirit.
    This worked. I opened Cydia and it asked if it could update itself, so I said yes.

    After the reboot Cydia started crashing everytime I opened it.

    Tried Re-Jailbreaking - No Luck
    Tried Rebooting - No Luck
    Supposedly I need to SSH into the phone and delete some Cydia files, but I need Cydia to install Open SSH
    Also I cannot use Rock as you need a working Cydia to do this.

    So the only options I can see are:
    1. Upgrade to 4.0 and forget the jailbreak
    2. Find someway to get into the phone and delete these Cydia files
    3. Restore to 3.1.3(But I came late to the Jailbreak game so I dont have my SHSH)

    Any ideas?

    Thanks
    06-30-2010 05:47 PM
  2. b0sanac's Avatar
    have you tried a full restore through itunes?

    it might work. you only need shsh if you need to downgrade to a previous FW. I would advise against upgrading to 4.0, as its relatively new it most likely has lots of bugs, and worst of all... no jailbreak for it yet.
    06-30-2010 07:13 PM
  3. Hack-My-i's Avatar
    ^if he tries to restore thru iTunes, it will ask him to update... just suck it up and update to iOS4, its actually pretty nice!

    ...or 1st, u can try iPhone Folders
    06-30-2010 07:21 PM
  4. matthew23's Avatar
    This happened to me awhile ago. Can't remember the fix but there is one. I don't have time right now but I think you could down load something from a computer and fix it that way. It was pretty easy and I seem to remember it had to be thru a windows-based computer. Don't upgrade as it can be fixed.
    06-30-2010 08:39 PM
  5. matthew23's Avatar
    Here u go: How to Fix Cydia Crashing on iPhone & iPod Touch 3.0. Download that and follow the directions. Worked for me awhile ago.
    06-30-2010 08:42 PM
LINK TO POST COPIED TO CLIPBOARD