1. robollama's Avatar
    I'm going to try to be as clear and detailed as possible, hopefully that'll help you guys help me

    Today I noticed my iPod Touch was dead, I think it had firmware 3.1.2 and since I jailbroke it using blackra1n tethered jailbreak I usually just hook up my iPod, and run blackra1n. This time however, blackra1n threw up the missing ASL.dll error (I had iTunes version 9.0.79 I think). So I looked up the error on Google, and placed the blackra1n.exe in the folder "C:\Program Files (x86)\Common Files\Apple\Apple Application Support\ASL.dll" like support sites told me to. So I then run blackra1n and it goes through the process, and displays the "If this was the easiest jailbreak ever..., etc." screen. After my iPod rebooted it was in the Recovery mode (iTunes logo and USB). So I tried the blackra1n process a few more times, sometimes it shows the geohot picture(frodo lookin guy) and sometimes just a black screen. Anyways it always ends up back in Recovery mode even after all my fiddling. I've tried to restore the iPod, and iTunes downloads the 3.1.3 firmware but I get an error from Apple saying "This device isn't eligible for this build" or something. I've also tried Shift + clicking Restore and choosing the firmware myself. I downloaded both firmware 3.1.2 and 3.1.3 and tried both but I get the same error as doing it the normal way(just clicking Restore). I've also now updated iTunes to 9.1.1 (NOT 9.2), but get the same results. Now, I'm left with an iPod Touch that's in the Recovery mode(iTunes logo and USB), that doesn't react properly to blackra1n or iTunes Restore. HELP??
    Last edited by robollama; 06-24-2010 at 04:24 PM.
    06-24-2010 04:20 PM
  2. Ipheuria's Avatar
    I don't know much about the touch but I'm just wondering which gen you have? and why not just go to iOS 4 and JB that?
    06-24-2010 04:30 PM
  3. robollama's Avatar
    3G iPod Touch, and I don't think you can jailbreak the iPod Touch 3G if it has iOS 4...
    06-24-2010 05:37 PM
LINK TO POST COPIED TO CLIPBOARD