1. Hypnotic iEyez's Avatar
    I hate to sound stupid but when it comes to technical stuff you could say that I am pretty naive. I have read a lot on jailbreaking, unlocking and upgrading IOS and I am still pretty confused.

    This is what I am working with:

    iPhone..............3Gs 16g
    iOS.................3.1.3 (7E18)
    Unlocked............Yes
    Jailbreaked.........Yes
    Tool User...........Spirit
    Bootrom.............? I don't have a clue what this is
    BootLoader..........6.4
    SHSH Saved..........Yes
    3.1.3, 4.0, 4.0.1, 4.0.2 and 4.1

    What I want to do is upgrade the IOS to at least 4.01, re-jailbreak and unlock. Will I need to re-virginize before upgrading the IOS? I have read about upgrading without upgrading the firmware (baseband) which is what I want to do.

    After reading this I am scared to do anything without some guidance:

    "I know lots of iPhone 3GS user still in 3.1.3 and worried about their iPhone. Good news is now you could JailBreak & Unlock iPhone 3GS easily but you should choose tools carefully as if you picked wrong tool you might lose any chance for future update too.

    Yes Its true, like if you use SpiritJB then you cant upgrade to iOS 4.0, as all iOS 4.0 JailBreak tools does not work with that"


    So does this mean because my iPhone was jailbroken with Spirit I will never be able to upgrade my IOS?

    I downloaded iPhone2,1_3.1.3_7E18_Restore.ipsw and redsn0w-win_0.9.4.zip, but to be completely honest I am scared sh*tless to do anything with it for fear of messing things up.

    I have to be honest and admit that I don't learn so well by just reading instructions, which makes Youtube a much needed help tool for me. So with that said anyone care to take me under their wings and walk me through this? Your help will be greatly appreciated. Thanks
    Last edited by Hypnotic iEyez; 12-28-2010 at 12:56 AM.
    12-26-2010 04:00 PM
  2. Hypnotic iEyez's Avatar
    Is there a way to upgrade from 3.1.3 to 4.0 only? I don't want to upgrade past 4.0 for now. If so how since iTunes wants to upgrade me to 4.2 (it is imperative that I can unlock). Any help is greatly appreciated. I am leaving for Denmark on January 1 and would like to buy a sim card to use there. I have 3gs with a 05.12.01 baseband. Currently jailbroken with Spirit and unlocked with ultrasn0w. The reason for wanting to upgrade before I leave is there are several apps I want to download that require at least IOS 4.0

    I know I have 3 different posts in this thread and I have done my best to search to find answers on my own. After all the searching and reading I am still very confused. Rather start a new thread I have kept my questions on this thread as per the rules. I really hope someone will help me. Please!!!
    Last edited by Hypnotic iEyez; 12-27-2010 at 08:56 PM.
    12-27-2010 08:10 PM
  3. larryganz's Avatar
    Is there a way to upgrade from 3.1.3 to 4.0 only? I don't want to upgrade past 4.0 for now. If so how since iTunes wants to upgrade me to 4.2 (it is imperative that I can unlock). Any help is greatly appreciated. I am leaving for Denmark on January 1 and would like to buy a sim card to use there. I have 3gs with a 05.12.01 baseband. Currently jailbroken with Spirit and unlocked with ultrasn0w. The reason for wanting to upgrade before I leave is there are several apps I want to download that require at least IOS 4.0

    I know I have 3 different posts in this thread and I have done my best to search to find answers on my own. After all the searching and reading I am still very confused. Rather start a new thread I have kept my questions on this thread as per the rules. I really hope someone will help me. Please!!!
    I cant go into exact step by step instructions without missing a step, but iclarified.com should have some tutorials. Since you saved your SHSH blobs on Cydia you should be able to do this using tiny umbrella and pawnage tool.

    With tiny umbrella (aka the firmware umbrella) you plug in the iPhone and fetch the SHSH blobs from cydia, and run the TSS server. This will have the tinyumbrella TSS server sign the ipsw package instead of Apple. Go to iClarified.com for instructions and links to get pwnage tool and the 4.01 ipsw file that you will modify with pawnage tool and install onto the iPhone. The instructions will tell you whether the phone needs to be put into recovery mode or DFU mode, and you'll do the option-restore in iTunes for Mac (not sure about PC) to install the modified ipsw file.

    This should not upgrade your baseband, and if the phone has never been past 3.1.3 then I believe it is unlockable. To unlock after JB you'd download ultrasn0w from Cydia.
    12-28-2010 11:46 AM
  4. iPhoneGleek's Avatar
    When I try to open Green Poison it crashes, what can I do?
    02-04-2011 05:42 PM
  5. rnr808's Avatar
    is there anyway to re install cydia packages??
    02-19-2011 05:59 AM
  6. rmx rider's Avatar
    I have a 4.2.1. sn0wbreeze custom firmware JB 3GS. Can't add any Mobile Me account because : "Validation Failed- The identity of this iphone could not be validated"


    PLEASE help!
    02-21-2011 08:19 PM
106 ... 345
LINK TO POST COPIED TO CLIPBOARD