1. Nht's Avatar
    Last night during multiple restore attempts on my friends iPhone 3g I repeatedly got error code 1015. Is there a workaround for this? To my understanding, 3g and under is allowed to restore to any firmware right? I downloaded the 3.1.2 firmware on felixburns website. Any ideas?? Thanks!
    05-18-2010 02:21 PM
  2. big9erfan's Avatar
    I think you'll have to put the phone into DFU mode to restore.
    05-18-2010 02:58 PM
  3. rdiddy_25's Avatar
    If u don't need to be unlocked, upgrade to 3.1.3 and use Spirit and ur done. Quik and painless.
    05-18-2010 03:06 PM
  4. Wiltron's Avatar
    1015 error is basically saying "Hey, your firmware wasnt signed by Apple, so F off"..

    If you have your SHSH files on Cydia's server, you'll be fine, just use iRecovery from Hackintosh to get out of the loop after you get the 1015 error. You'll be fine then.

    If you don't rely on a carrier unlock, upgrade to 3.1.3 and use SpiritJB
    05-18-2010 03:10 PM
  5. big9erfan's Avatar
    1015 error is basically saying "Hey, your firmware wasnt signed by Apple, so F off"..

    If you have your SHSH files on Cydia's server, you'll be fine, just use iRecovery from Hackintosh to get out of the loop after you get the 1015 error. You'll be fine then.

    If you don't rely on a carrier unlock, upgrade to 3.1.3 and use SpiritJB
    It's a 3G, there are no SHSH files or signed firmware for the 3G.
    05-18-2010 03:16 PM
  6. Nht's Avatar
    So where does that leave me? I need it to be jailbroken and unlocked. Will irecovery work in my case to override the 1015? This phone has never jailbroken before if that makes a difference
    05-18-2010 11:02 PM
  7. Nht's Avatar
    Ok last night I was finally able to jailbreak to 3.1.2. This was achieved by ignoring the 1015 error and shortly after just ran Blackra1n. This kicked it out of restore mode.

    However now I'm faced with a new problem. I'm beginning to suspect that the iPhone previously had firmware 3.1.3 on it because I tried the blacksnow unlock several times but it didn't work. Also I checked the baseband and it's at 5.12.07. Is there an unlock that will work or am I SOL for the time being? Thanks
    05-19-2010 07:25 PM
  8. lungho's Avatar
    Yeah, there is currently no unlock for 5.12.07. We'll have to wait until 4.0 and hopefully dev team, geo, or whoever will also release an unlock in addition to a jailbreak.
    05-19-2010 07:58 PM
  9. en0c's Avatar
    05.12.07? Don't you mean 05.12.01?
    05-20-2010 02:00 PM
LINK TO POST COPIED TO CLIPBOARD