1. driverm's Avatar
    Hi.
    I have a 3GS with 3.1.2 OS jailbroken and simlocked by blackra1n and blacksnow. 2 days ago, I downloaded a photograph app from itunes app store. I bought it officially. and a day after that my iphone suddenly restarted itself while i was talking on the phone. It was starting itself over and over again, getting stuck on the apple logo screen. I tried many things that i could find on the internet. However, many of them didnt worked. (iPhone Browser, IPhone Explorer didnt worked also. Those didnt recognize my iphone even if iphone was at recovery stage.)

    Now I m trying the solution, stated at this article.
    (ihackintosh.com/2009/09/recover-iphone-3gs-from-apple-logo-or-recovery-mode-loop/)

    I put the iphone into recovery mode, starting the terminal and it successfully recognizes my iphone. However after that none of my commands are being recognized by the terminal, as an example, my terminal output:

    (Recovery) iPhone$ setenv auto-boot true
    (Recovery) iPhone$ saveenvs
    (Recovery) iPhone$ fsboot

    Even if i write myiphonesucks as a command, terminal doesnt give any response to it such as:

    (Recovery) iPhone$ myiphonesucks
    (Recovery) iPhone$

    However, after connecting the iphone through, iRecovery -s, I only can use reboot command. Interestingly it only recognizes this command. Not even fsboot

    I also can not SSH into my iphone as I mentioned earlier. iPhone browser or any other software does not recognize my phone even at the recovery stage.

    I dont want to restore my iphone with itunes because it wants to update the software with the latest one, which is 3.1.3, and which blackrain has not yet created an update for it. I need to unlock the sim for using it but without blackrain, i cannot.

    Please help me, I need my iPhone so much these days. As part of my job, I need to look at my mails while I am away too, but w/o my iphone, it really is impossible for me.

    This really is urgent! Please help me.

    Thanks alot.
    Last edited by driverm; 04-19-2010 at 09:40 AM.
    04-19-2010 09:16 AM
  2. LVCIFER's Avatar
    I had pretty much the same situation as you where I got stuck in the boot loop.

    DO NOT OFFICIALLY RESTORE.

    First things first - did you have a tethered jailbreak?
    04-19-2010 10:02 AM
  3. LVCIFER's Avatar
    I'll try to get you through this,
    DM me on Twitter (@FEARtheSERVER)
    or
    IM me on AIM: The iPhone God
    04-19-2010 10:03 AM
  4. xescuy's Avatar
    Hello lvcifer, driverm
    I have the exact same issue after resetting my wifi settings. Phone stuck in apple logo screen. Same device/OS
    The only thing I need is my contacts but really badly

    - untethered JB
    - iRecovery tool - same results as driverm (after installing 64bit libusb with all the "fun" that involves)
    - attempted editing com.apple.SpringBoard.plist - unable to access (SSH, iPhoneBrwser, iFunBox, iTunnel)
    - unfortunately I happened to turn SSH off in my SBSettings a bit before the crash so maybe that's why is not doing it, plus SSH is through wifi which I'm sure is not on at the apple logo
    - finally I noticed that the battery is not charging or only charging a little bit at a time (USB ports should be fine, iTunes sees it when I put it in recovery mode)
    So ... any ideas
    Is there a way to SSH into the device through USB?
    Can you think of any other way of accessing the SpringBoard.plist?
    Should these operations be done in recovery mode, DFU mode?
    I have available Win7 64bit and Ubuntu 10.04 64bit (no Mac but I might be able to recompile something for Linux)
    I'm willing to go as far as necessary as long as it does not involve soldering

    Any assistance would be greatly appreciated
    Cheers
    X
    05-24-2010 09:28 AM
  5. LVCIFER's Avatar
    Do you require an unlock? And for your contacts, have you backed up via iTunes recently?
    05-24-2010 11:37 AM
  6. soulfulzeta's Avatar
    I'll try to get you through this,
    DM me on Twitter (@FEARtheSERVER)
    or
    IM me on AIM: The iPhone God
    I so wish you were in the forums last night. I really needed you but it's too late now. You seem to know exactly what you're doing.
    05-24-2010 12:03 PM
  7. xescuy's Avatar
    Do you require an unlock? And for your contacts, have you backed up via iTunes recently?
    Will need unlock
    I have 3.1.2 and 3.1.3 SHSH blobs on Saurik's server
    Backup done in itunes but gone when reinstalling win7 so it's gone bye bye.
    Any ideas?
    ***
    05-24-2010 12:33 PM
  8. aceman's Avatar
    ok guys i need your help..

    i have 3gs with 3.1.2 , broadband 5.11.7 i think, week 48, its was unlocked with blackrain and jailbroken with Citia.

    I had an issue with Citia which crashed, i used directions with something called SSH to delate citia. Now Blackrain does not work, i "let it rain" and the phone just keeps going, its does not reboot back. I tried this so many times and nothing. Everything was working fine before, it only happed when i took off citia. i am running Itunes 9.1, would it help if i tried it with 8.9?

    please please help, i cant use this phone, becuase i am not using ATT...
    should i upgrade to 3.1.1 and restore settings? can you unlock 3.1.1 yet?
    05-25-2010 06:13 AM
  9. xescuy's Avatar
    sorry aceman ...
    do you mean Cydia ?
    If you can still ssh into the phone just restore your files or edit SpringBoard.plist -do a search in google- should be plenty of info there.
    If not ... I don't know, hopefully LVCIFER can help
    05-25-2010 08:20 AM
  10. aceman's Avatar
    i do mean Cydia yes...

    i tried to log in again to SSH, but the siftware could not find the phone....i guess its not finding the IP address or something like this...

    LVCIFER any help ? anybody ?
    05-25-2010 09:05 AM
  11. LVCIFER's Avatar
    Ok, screw this, I'll be honest, I keep forgetting to check the forums because I've been a bit busy lately, so ALL OF YOU, send me an e-Mail at FEARtheSERVER@gmail.com with your specific problem, and I will do what I can to help you guys out.
    05-25-2010 09:12 AM
  12. xescuy's Avatar
    Have you tried iRestore already? Hope you don't have a 64bit system. It's a damn hassle. But it might save your a$$
    And keep searching ... you might find more info than I did and come up with a solution.
    Good luck
    05-25-2010 09:46 AM
  13. aceman's Avatar
    i have Windows Vista 32Bit, i thought irestore was only for Mac? is this true ?
    05-25-2010 09:53 AM
  14. aceman's Avatar
    whats is irestore, do you have a link for it ?
    05-25-2010 09:57 AM
  15. xescuy's Avatar
    whats is irestore, do you have a link for it ?
    do a google search on iRecovery it or try this
    ihackintosh.com/2009/07/irecovery-iphone-recovery-mode-loop-restart/
    05-25-2010 11:48 AM
  16. aceman's Avatar
    hey bro Solved...i found a guy online who came to my house for about 50$, he fixed it, not sure what he did, but he upgraded me to 3.1.3, but left me the old modem Firmware at 5.11.07. now its sim free, unlocked, plus everytime i close the phone i dont have to connect it to the computer, no blackrain....not sure what he did, but he is a KING...
    05-26-2010 06:28 AM
  17. netster's Avatar
    Hi I have a 3gs 32gb iphone, which had been jailbroken on 3.1.2.

    I had updated it to ios 4 custom firmware, all was good.

    My phone got wet on holiday and got itself into a bit of a flap, but after an hour drying it out with a hair drying, the moisture in the screen disappeared, and the phone/screen came back to life, BUT the phone was now stuck in the logo/spining wheel/reboot cycle.

    On returning from hols I put the phone into the recovery mode, then restored the ios 4, the phone took the firmware, but still stuck in reboot loop.

    The funny thing is, that itunes can see the phone, I can even copy music to it, but on the device itself it still is only showing the apple logo, then after a while the logo + spinning wheel, then after a few minutes it reboots.


    I have tried irecovery, this has not ended the loop.

    I have managed to downgrade to 3.1.2, then run the blackra1n jailbreak the phone, but still stuck in reboot loop.

    Can anyone help/explain what is going on?
    07-14-2010 11:59 AM
LINK TO POST COPIED TO CLIPBOARD