1. beatles062's Avatar
    I had my iphone unlocked .... but it isn't working .... I was told it wont work to unlock it for at&t is this true? I had it unlocked before and it worked .. I have a old at&t plan that I don't want to get out of so that's why I want it unlocked for at&t ...... would appreciate any help or advice
    03-15-2010 05:33 PM
  2. LVCIFER's Avatar
    Ok, what was the original carrier of the phone?

    If it was in the US, it would have been locked to AT&T. If you have an old AT&T account, just use that SIM Card. Free a few days, AT&T will upgrade your old account to an AT&T iPhone account. The prices will be modified, obviously, however there is no need to unlock it at all, IF YOUR ORIGINAL CARRIER was AT&T.

    So get back to me on that one.
    03-15-2010 05:53 PM
  3. beatles062's Avatar
    the original carrier I think was roger in canada .. the reason I don't want to upgrade my account it would cost me about $65 more a month for less minutes. this phone was unlocked when I got it I just didn't have the internet package.can it be unlocked for at&t ?
    03-15-2010 06:10 PM
  4. LVCIFER's Avatar
    Here's the problem - if you use an iPhone on AT&T, they have detectors that AUTOMATICALLY force your account to upgrade to the iPhone account.

    There's no way out of that. BUT, to answer your questions - I'll need a little bit more info.

    Go to Settings>General>About, and tell me the following:

    1) What iPhone do you have? 2G, 3G, or 3G[s]?
    2) What firmware/version do you have?
    3) What is your baseband/modem firmware?

    Let's start with that and go from there.
    03-15-2010 06:17 PM
  5. beatles062's Avatar
    the iPhone is 3G
    The modom firmware is 05.12.01
    The version is 3.1.3 (7E18)
    model # MB704LL
    Serial # 88847GOVY7K

    Is this what your looking for ....... Thanks for the help

    Let's start with that and go from there.
    03-15-2010 06:25 PM
  6. LVCIFER's Avatar
    Ahh, and here is the problem - 3.1.3 can't be jailbroken or unlocked unless you were PREVIOUSLY jailbroken/unlocked at the time of upgrade. Your baseband is 5.12, which at the current time cannot be unlocked. However, in the next few weeks, you should be in luck as there will most likely be a new unlocking tool released.

    At the current time, there's literally NOTHING that can e done to fix your predicament.

    Sorry man.
    03-15-2010 06:47 PM
  7. beatles062's Avatar
    Thanks any ways
    03-15-2010 06:54 PM
  8. LVCIFER's Avatar
    Keep coming back here, that way you'll know when it CAN be jailbroken and unlocked.
    03-15-2010 07:22 PM
  9. beatles062's Avatar
    I will thanks again
    03-15-2010 07:37 PM
  10. soulfulzeta's Avatar
    Question. I'm with AT&T and I have the 3gs. However, I want to unlock the phone so I can use it overseas. Where do I go to be able to do this? This phone is running 3.1.2. (7D11) with a modem firmware of 05.11.07. Thank God Apple gave me a different phone with the old firmware. I just want to be able to relax in Jamaica and use the Digicell SIM card without any problems when I'm there.

    Here's the problem - if you use an iPhone on AT&T, they have detectors that AUTOMATICALLY force your account to upgrade to the iPhone account.

    There's no way out of that. BUT, to answer your questions - I'll need a little bit more info.

    Go to Settings>General>About, and tell me the following:

    1) What iPhone do you have? 2G, 3G, or 3G[s]?
    2) What firmware/version do you have?
    3) What is your baseband/modem firmware?

    Let's start with that and go from there.
    03-16-2010 03:25 PM
  11. en0c's Avatar
    Jailbreak with blackra1n and unlock with sn0w
    03-17-2010 05:49 PM
  12. LVCIFER's Avatar
    Blacksn0w won't work on his firmware. It's 5.12, not 5.11.
    03-17-2010 07:49 PM
  13. en0c's Avatar
    It was a reply to that other guy who hijacked the thread And I'm writing from my iPhone, so there isn't a quote button...
    03-18-2010 06:28 PM
  14. LVCIFER's Avatar
    I feel your pain. I always write from my iPhone.
    03-18-2010 06:56 PM
LINK TO POST COPIED TO CLIPBOARD