1. subaruRXgal's Avatar
    Hi guys. I just tried to backup, restore, unlock, and jailbreak my iphone (METAL CASING) I used the blackra!n method and everything runs as follows, until it pops up with a screen "ENJOY YOUR JAILBROKEN IPHONE!" Then, I wait for the iPhone to reboot, and it returns to the screen that shows the USB - arrow - iTunes. Also, if I launch iTunes I get the following message: "The SIMCard inserted in this iPhone does not appear to be supported. Only compatable SIMCards from supported carrier may be used to activate iPhone. Please insert the SIMCard that came with your iphone or visit a supported carrier store to receive a replacement SIMCard."

    I bought this phone hacked and jailbroken and a friend "wanted to jailbreak it with a current version." I am on T-Mobile, and am currently f*cked with no phone. Any advice would be much obliged.
    01-29-2010 05:28 AM
  2. en0c's Avatar
    Restore, set it up as new, jailbreak with blackra1n and unlock with bootneuter. Guide here: Jailbreak Unlock iPhone 2G 3.1.2 Firmware with blackra1n RC3 | Redmond Pie
    01-29-2010 11:24 AM
  3. spsands's Avatar
    Restore, set it up as new, jailbreak with blackra1n and unlock with bootneuter. Guide here: Jailbreak Unlock iPhone 2G 3.1.2 Firmware with blackra1n RC3 | Redmond Pie
    I have followed these instructions here and from LVcifer to a tee, several times, and everytime I get a "different sim detected" "please connect to itunes"
    with the tmobile sim,

    the Att sim seems to be fine

    or even when there is no sim card in it at all, I can get beyond the emergency call screen
    01-29-2010 01:21 PM
  4. LVCIFER's Avatar
    Have you tried running blackra1n AGAIN instead of connecting to iTunes when you get that message?

    It just may be a small hacktivation problem that's happening.
    01-29-2010 01:27 PM
  5. spsands's Avatar
    Have you tried running blackra1n AGAIN instead of connecting to iTunes when you get that message?

    It just may be a small hacktivation problem that's happening.
    Yeah,

    did that, am restoring and trying jailbreak with the Tmobile sim in the whole time this time...

    last couple times I used the Att sim to jailbreak and unlock, then put in the tmobile one and got the sim card errors and emergency call screen...
    01-29-2010 01:30 PM
  6. spsands's Avatar
    Ok, so after a zillion times of trying to jailbreak, unlock on the att sim then put in the tmobile sim and getting an error,

    I left the tmobile sim card in, put it in dfu mode, restored with itunes, then ran blackra1n one more time...

    it came up with the Tmobile sim and now I am downloading cydia and Rock...

    apparently, boot-neuter flashes are permanent?? cuz I have a working, jailbroken/unlocked 2g phone, but right now, boot-neuter is not installed... it was removed by my restore...
    01-29-2010 01:40 PM
  7. spsands's Avatar
    WOW...
    what a pain...

    everything was working fine on Tmobile, installed winterboard, it rebooted the phone,

    it came up with the apple then went dark, I hard rebooted, apple came up for a bit and went dark...

    I plugged it in, ran blackra1n and its waiting for device, I turn on the phone, apple comes up and goes dark before blackra1n can do anything..

    whats up now?
    01-29-2010 01:57 PM
  8. spsands's Avatar
    ok, so I did the above steps...

    then put it in dfu as it came up, and blackra1n ran, said was successful, said wait for reboot,

    and then the phone dies...

    never comes up

    Cant get beyond the apple...
    01-29-2010 02:07 PM
  9. spsands's Avatar
    put it in recovery mode again, restored to itunes again,

    and then rejailbroke...

    things are working ok again, I know you have to run Blackra1n everytime the phone is rebooted or turned off, but Im wondering if there is a problem with the reboot after an install of winterboard...

    does anyone have winterboard on their 2g iphones that is jailbroken and unlocked on tmobile???
    01-29-2010 02:41 PM
LINK TO POST COPIED TO CLIPBOARD