1. LuisT#IM's Avatar
    Well, I got my iPhone last month (1st Generation 8 Gig). It is unlocked to T-Mobile and jailbroken with blackra1n and bootneuter. I was wondering why my Push Notifications aren't working? They never seem to be working. Like I have them on and stuff, plus I downloaded the "push and youtube fix" on Cydia and it still doesn't work?

    Any help!?

    Thanks.
    01-06-2010 11:30 PM
  2. dvigue's Avatar
    push wont work on hactivated iphones....
    01-07-2010 09:41 AM
  3. flyingember's Avatar
    another aspect that proves jailbreak includes the word break. jailbreaking is not risk free and if you want all advertised features to definently work you don't jailbreak.

    the benefits can be worth the downsides, however.
    01-07-2010 10:13 AM
  4. Alli's Avatar
    Depends on the app, too. I get my push notifications (I'm jailbroken) for most everything. But...I get no badges on Boxcar (although I do get text notifications). I get badges with the new Facebook app, and I get all possible push notifications with WhatsApp.
    01-07-2010 01:12 PM
  5. BreakingKayfabe's Avatar
    Depends on the app, too. I get my push notifications (I'm jailbroken) for most everything. But...I get no badges on Boxcar (although I do get text notifications). I get badges with the new Facebook app, and I get all possible push notifications with WhatsApp.
    I'm jailbroken as well and push email used to work flawlessly. After I installed
    the new FB app yesterday the push notifications weren't working. I did many
    things from installing to re-installing, to re-booting and nothing. I then realized
    that my push for BeeJive doesn't work either. So basically I'm not getting push
    for email or any apps that use push eventhough my settings are set accordingly.

    I installed the push toggle for sbsettings. I turned it off and then on. Now
    whenever I do that I get the "connect to iTunes for push notifications" popup
    when I open an app that uses push, such as FB. I connect to itunes, do my
    sync and still nothing. Any suggestions? I've been baffled with this and I'm
    also sure this is why my Yahoo push email hasn't worked right either.
    01-07-2010 01:23 PM
  6. LVCIFER's Avatar
    Have you installed "PushFix" from the SiNfuL iPhone repo?
    01-07-2010 02:45 PM
  7. BreakingKayfabe's Avatar
    Ever since I re-jailbroke I've followed the steps of adding the http://cydia.iphoneil.net
    I haven't been able to find the "push fix" in any of the searching. Any idea why?
    01-07-2010 03:02 PM
  8. Zoso1048's Avatar
    Ever since I re-jailbroke I've followed the steps of adding the http://cydia.iphoneil.net
    I haven't been able to find the "push fix" in any of the searching. Any idea why?
    Seconded. I'm bummed about my push being gone.

    It's weird though. I actually had to JB about 3 times, for various reasons. The second time around, push was working...after that, nada.
    01-25-2010 12:52 AM
LINK TO POST COPIED TO CLIPBOARD