1. esspee5's Avatar


    Hi people i am all new to these forums but i am at me wits end with this problem PLEASE HELP !!!!!!!!!!!!!

    QUICK OVERVIEW i am trying to ssh into my iphone 3GS 3.1.2 using winscp with now suck look.
    i am using a desktop pc with windows xp sp2 i have a netgear router WNR2000

    i put in the details :host name (iphone IP)
    username :root
    password : dottie or alpine (neither works)
    Port 22
    change server responce timeout - 45 secs
    file protocol SFTP -and allow scp fallback

    All i get is "connection error network timeout"

    what am i doing wrong do i need to change something in my router are my settings wrong ???? driving me MAD coz the tutorial vids on youtube make it look so easy .

    also 1 more thing ive noticed if i try and change my SSH password it wont accept the original as "alpine or dottie"


    PLEASE HELP !!!!!!!!!!!!!!!!!
    01-05-2010 01:42 PM
  2. DainBramage1's Avatar
    I got the same error until selecting SCP for the File Protocol.
    01-05-2010 02:02 PM
  3. lungho's Avatar
    Usually a "connection error network timeout" means you haven't set something up quite right. It may have something to do with your ip address and/or DHCP because everything else looks right.

    Me personally?? I got this same error message when my phone was configured to use DHCP on my network at home. Even though the ip address was right, I couldn't connect. I ended up assigning a static ip address to my phone. Only then was I able to connect with winscp.

    Not saying this is a fix-all. This is simply what worked for me.
    01-05-2010 06:35 PM
  4. esspee5's Avatar
    thanks buddy ill give it a go !!

    but im sure ive tried SCP aswell ...............


    what else could my iphone ssh password be seems strange i cannot change it from dottie or alpine .................. mmmmmmmmmm!!!!!!!!!!!!
    01-06-2010 11:28 AM
  5. esspee5's Avatar
    i am on a uk network "ORANGE" have they secured it somehow x x
    01-06-2010 11:29 AM
  6. bamf-hacker's Avatar
    I see you have been able to ssh to the phone to try and change the PW. Did you use terminal on the phone or something like putty on your Windows PC?

    As for WinSCP your settings are correct, as long as the device is connected to the same network segment you are on. Also are you sure SSH is enabled on the phone? Install SBSettings if you have not already and make sure SSH is on.
    01-06-2010 03:19 PM
LINK TO POST COPIED TO CLIPBOARD