1. jailbreak111's Avatar
    Hi Guys,

    I recently downloaded "OpenSSH" from Cydia and am using WinSCP to try and get into my iphone Directories, however I seem to have folders missing.
    As in, when I go into root > Library all i get are address book, caches, keyboard, lockdown, preferences, webkit.
    So no ringtones or photos etc. My media folder btw is empty.

    I have tried other programs like filezilla and putty but still same result.
    Please can anyone help me with this?

    Thanks!
    A.C.
    01-02-2010 06:58 PM
  2. anon(153966)'s Avatar
    I wonder if you have to change the explorer view to show hidden files\folders...
    01-02-2010 10:24 PM
  3. lungho's Avatar
    Hi Guys,

    I recently downloaded "OpenSSH" from Cydia and am using WinSCP to try and get into my iphone Directories, however I seem to have folders missing.
    As in, when I go into root > Library all i get are address book, caches, keyboard, lockdown, preferences, webkit.
    So no ringtones or photos etc. My media folder btw is empty.
    A.C.
    First off, this is normal.

    Winscp starts up into the /private/var/root folder by default instead of the /<root> directory. "/private/var/root" and "<root>" are not the same. Often I have to use the method described below before I can find the right directory to transfer a custom email or sms tone.

    Look at the button bar above the folder view. This shows you the directory path. There is also a button with an arrow pointing up. This is the parent directory button. Keep pressing that button until you reach the /<root> directory. This will get you to the very beginning of the directory structure.
    01-02-2010 10:55 PM
  4. DainBramage1's Avatar
    I wonder if you have to change the explorer view to show hidden files\folders...
    That doesn't sound familiar... the only thing I had to do besides put in my IP address, username and password was change the File Protocol to SCP. You're viewing it from within WinSCP, right?
    01-02-2010 11:00 PM
  5. jailbreak111's Avatar
    Lungho, thank you very much this was the reason why it wasnt working! I can now see all the folders.
    For those who might have similar problems you can either press the up arrow folder icon as Lungho says or press the folder icon with the "/" in it. This takes you to the root directory.
    Thanks for your replies
    01-03-2010 10:27 AM
LINK TO POST COPIED TO CLIPBOARD