1. Mythico's Avatar
    This has been happening for a while now and haven't been able to figure it out, so I decided to take it to the fourms

    When ever I try to add or remove a source (doesn't matter which one) it gets stuck at updating sources(at the top of the screen) and downloading packages(bottom of the screen). It just hangs at that screen I dont get any error messages or anything it just hangs at that screen. Anyone have any ideas?
    12-05-2009 10:37 AM
  2. jglowe74's Avatar
    are you JB on 3.0.1 or 3.1.2? and if 3.1.2, did you JB using the latest blackra1n? i think there is RC3 out now. and i also assume you have 3G/3GS, yes?
    12-05-2009 10:59 AM
  3. Mythico's Avatar
    are you JB on 3.0.1 or 3.1.2? and if 3.1.2, did you JB using the latest blackra1n? i think there is RC3 out now. and i also assume you have 3G/3GS, yes?
    I JB on 3.0 (7A341) at least thats what my options show I currently have and I havn't updated
    I JB using redsn0w, and yes I am using the 3GS.
    12-05-2009 11:02 AM
  4. jglowe74's Avatar
    I JB on 3.0 (7A341) at least thats what my options show I currently have and I havn't updated
    I JB using redsn0w, and yes I am using the 3GS.
    i was running redsn0w on my 3gs before 3.1 came out like you. but cydia started acting up on me as well. i decided not to take the plunge into 3.1 (basically, for MMS) until another JB came out. that's when i switched to blackra1n. i'd guess cydia is getting buggy because the JB you have is getting dated.

    might try doing a backup/sync through iTunes. then install 3.1.2 firmware and re-JB using blackra1n. i've had zero issues running blackra1n. and it's super-easy to install.
    12-05-2009 11:06 AM
  5. Mythico's Avatar
    i was running redsn0w on my 3gs before 3.1 came out like you. but cydia started acting up on me as well. i decided not to take the plunge into 3.1 (basically, for MMS) until another JB came out. that's when i switched to blackra1n. i'd guess cydia is getting buggy because the JB you have is getting dated.

    might try doing a backup/sync through iTunes. then install 3.1.2 firmware and re-JB using blackra1n. i've had zero issues running blackra1n. and it's super-easy to install.
    Thanks.I have to head out soon but maybe I will try that out when I get back. Now just to figure out how to backup my cydia apps before I do this. That or write them down hehe
    12-05-2009 11:18 AM
  6. MustangLife's Avatar
    I agree, I would backup sync through Itunes, update to 3.1.2 and use Blackra1n and you'll be good to go.

    Josh
    12-05-2009 11:28 AM
  7. jglowe74's Avatar
    Thanks.I have to head out soon but maybe I will try that out when I get back. Now just to figure out how to backup my cydia apps before I do this. That or write them down hehe
    you can download AptBackup in cydia. it will allow you to backup JB apps. then after re-JB, download AptBackup as your first cydia app. then you can restore from there. pretty sure it worked for me.

    i also wrote down every JB app i had, as well as themes, sources, etc. helped me figure out what i needed to download after my fresh JB. just in case AptBackup doesn't work completely. :/ better safe than sorry
    12-05-2009 12:16 PM
  8. Mythico's Avatar
    So I did a backup through cydia and through itunes. Then I did a restore through itunes. After I did that i got an error message on the iphone asking me to hook it up to the computer and wasn't being detected in itunes. I only got the option for emergency calls other then that it was just asking to be hooked up to the PC. I tried starting itunes and reconnecting and still wouldn't detect it. I tried going into recovery mode (I think thats home and power button held down) and the iphone turned off. It will no longer turn on. Any suggestions?
    12-05-2009 01:35 PM
  9. Mythico's Avatar
    Ok, so I managed to get it back on. I just had to hold both the buttons down for longer then I was trying before and it came back on. I am still stuck at the screen asking me to hook it up to itunes and I tunes wont detect it. Any suggestions?
    12-05-2009 01:39 PM
  10. Mythico's Avatar
    I have restarted the apple mobile device service, and the itunes service and it detected my iphone again. I then restored again and it worked. Now to re-jailbreak
    12-05-2009 01:42 PM
  11. IGoSlo's Avatar
    I beleive with the 3GS if your iPhone looses power or is shut down it needs to be JB'n again. Make sure your battery is FULLY Charged. Try and repower and start again... Sorry that's the best I can offer... I'm on 3G iPone and the 3GS and Jail Breaking are slightly different. iGlowe74 should have more reputable answers for you. GOOD LUCK
    12-05-2009 01:47 PM
  12. Mythico's Avatar
    It is now re-jail broken. I just installed cydia and seems to be working fine. I think what your talking about is only true for the newer the 3GS. I think the older ones dont have that problem. Then again I am not 100% sure on that.

    Also to add it seemed to resolve the problem with adding/removing sources
    12-05-2009 02:01 PM
LINK TO POST COPIED TO CLIPBOARD