1. cmefly#IM's Avatar
    I have a first gen iPhone version 2.1.
    It's jailbroken. works fine. But I like to upgrade to the latest version. Don't care about Cydia. ( I have another iPhone which is jailbroken and unlocked)
    So the Questions I have: How do I do this? Just restore the phone on iTunes?
    Will it work after I restored and upgraded it? Will all the apps be there?

    Thanks for any tips and helps !!! :-)
    11-20-2009 08:42 AM
  2. Allyson Kazmucha's Avatar
    upgrade your phone to 3.1.2 and either use blackra1n RC3 or Pwnage Tool 3.1.4
    11-21-2009 03:57 AM
  3. LVCIFER's Avatar
    If it's an iPhone 2G, in order to unlock you'll still need BootNeuter. But blackra1n should work just fine.
    11-21-2009 07:57 AM
  4. Allyson Kazmucha's Avatar
    If it's an iPhone 2G, in order to unlock you'll still need BootNeuter. But blackra1n should work just fine.
    I do not think you need BootNeuter. Ultrasn0w will unlock 2G iPhones. I could be wrong as I haven't unlocked an iPhone in quite some time as I've always had AT&T. I've done it for a few friends though.

    I unlocked my friend's 2G iPhone on 3.0 and did not use BootNeuter whatsoever. I was actually told NOT to use it as it. This was before the baseband upgrade though.
    11-22-2009 04:25 AM
LINK TO POST COPIED TO CLIPBOARD