1. wdkwang's Avatar
    FYI, I've jailbroken my 1st and 2nd iphones before, and now I want to jb my 3gs. I've had/have AT&T with all of them. The 3GS came with 3.1 firmware, and I updated it to 3.1.2 through itunes, as well as the baseband. Now my main concern is that I want to jailbreak it, without permanently bricking it as I'm worried with what I've read with the recent postings.

    I know that with AT&T you don't need to unlock it but what happened with me and my previous 3G was that I didn't have service after i jailbreaked it. This worried me until I just gave the cydia unlock a try and it worked. I have no idea why that happened but it did.

    So as of rite now, I see GeoHot with his release, and quickpwn for macs only.
    Bottom line, how do I correctly jailbreak my AT&T virgin 3GS 3.1.2?
    10-14-2009 09:02 AM
  2. Ipheuria's Avatar
    You guys have seriously got to start searching since the weekend this is probably the 8th thread I've seen asking about JBing steps with two threads created containing links to the steps.

    Windows using blackra1n
    Jailbreak iphone 3.1.2 with blackra1n | TechnoBuzz.net

    Mac using pwnage tool
    Jailbreak iPhone 3.1.2 with PwnageTool 3.1.4 | TechnoBuzz.net

    Read whichever one you need and make sure you have the necessary software, ipsw file, etc. for the Jailbreak(JB). If you JB and you find problems on your phone then just connect to iTunes and click restore it will restore the phone back to factory settings and undo the JB.
    10-14-2009 09:11 AM
  3. LVCIFER's Avatar
    Not 100% sure about this, but while this topic is active, if I have a 3G running official 3.0, downloading blackra1n should allow me to jailbreak successfully, right. Since Geohot sTated that it would break any device on any OS, I just want to confirm.
    10-14-2009 09:51 AM
  4. shutter's Avatar
    blackra1n jailbreaks 3.1.X firmware. It will not JB 3.0. So you would have to upgrade to 3.1 or 3.1.2.
    10-14-2009 11:04 AM
  5. LVCIFER's Avatar
    What about redsn0w?

    Because I just want to jailbreak my current 3G so that I can use a Pwnage Tool created ipsw so that I can upgrade while retaining my unlock.

    So if I used redsn0w to jailbreak 3.0, then use the Pwnage Tool 3.1.2 ipsw to upgrade to current, would that work?
    10-14-2009 11:06 AM
  6. shutter's Avatar
    Yes, provided you have a mac, pwnage tool is mac only. To be clear, to preserve your baseband...you have to use pwnage tool. If your not on a mac. you can find a custom ipsw on the net somewhere, I'm sure. That's what I did with 3.1 before geohot released blackra1n for windows.

    edit* I just noticed you already have the custom ipsw, if you have it an trust it, you can use it on a mac or windows using shift/option + click restore in iTunes.
    10-14-2009 11:10 AM
  7. LVCIFER's Avatar
    Oh, I trust the source. It was created with Pwnage on Mac, but my issue - the issue that I'm just slightly unclear about - is that the Devzteam sates that to USE a pwnage ipsw, hour phone has to Be currently jailbroken. My wife's 3G WAS PREVIOUSLY jailbroken, but isn't CURRENTLY jailbroken. She is also running stock 3.0. So basically, I need the tools to re-jailbreak her current stock 3.0, and then once it's jailbroken, restore using the pwnage ipsw to 3.1.2.

    I just wanted to be clear on this so that it could be able to work seamlessly, and without problems.

    Long story short, I just have to jailbreak before I restore to New 3.1.2. I'm just not sure which tool I'd use to do it.

    I think, by all accounts, it SHOULD be redsn0w, correct?

    I just need to know if the CURRENT version of redsn0w will still jailbreak 3.0.
    10-14-2009 12:24 PM
  8. shutter's Avatar
    Oh, I trust the source. It was created with Pwnage on Mac, but my issue - the issue that I'm just slightly unclear about - is that the Devzteam sates that to USE a pwnage ipsw, hour phone has to Be currently jailbroken. My wife's 3G WAS PREVIOUSLY jailbroken, but isn't CURRENTLY jailbroken. She is also running stock 3.0. So basically, I need the tools to re-jailbreak her current stock 3.0, and then once it's jailbroken, restore using the pwnage ipsw to 3.1.2.

    I just wanted to be clear on this so that it could be able to work seamlessly, and without problems.

    Long story short, I just have to jailbreak before I restore to New 3.1.2. I'm just not sure which tool I'd use to do it.

    I think, by all accounts, it SHOULD be redsn0w, correct?

    I just need to know if the CURRENT version of redsn0w will still jailbreak 3.0.
    Sorry I didn't get back to this earlier, been away from the internet most of the day.

    At any rate, my understanding is it would not matter whether you used purplera1n or redsn0w. Just so long as you were jailbroken. But since your going to go with a pwnage custom ipsw...I would use redsn0w, just seems fitting.
    10-14-2009 10:35 PM
  9. JarJarT's Avatar
    Successful 3.1.2 jailbreak in the end (4th attempt): ended up with Apps from iTunes not loading (everything else OK?!?!). So here's what i did: Deleted all iTunes Apps (made a list of all apps first) in iTunes & iPhone. Made a custom IPSW with Pwnagetool 3.1.4, chose do not activate, partition 1029 mB, install Cydia only. Previous to this I installed Rock app and made a backup of all Cydia apps, great tool. Now reinstalled iTunes apps from scratch after JB and 'I haz success' Oh I forgot, restore to new Phone NOT backup !!
    Last edited by JarJarT; 10-17-2009 at 09:15 AM. Reason: Restore edit !?
    10-17-2009 09:14 AM
  10. DaPeeps's Avatar
    IMHO the best way is to find someone who created a custom IPW with pwnagetool and do it that way. Too many issues with that Blackrain from what I've heard. I've always JB'ed with a DevTeam method, and I will stick with that.

    I didnt have a Mac to run it on, so I created my own I run OSX 10.5.8 on a PC Laptop I have, and it runs great Hackintosh FTW!
    10-17-2009 09:38 AM
LINK TO POST COPIED TO CLIPBOARD