1. allabout17's Avatar
    It says that in order to download the carrier update you have to have OS 3.1. I have a jailbroken 3G S running 3.0, anyone know if there is a way around this? I knew they were going to do this!!
    09-25-2009 01:44 PM
  2. Matt74's Avatar
    Been able to do this for a long time.... Hack to Enable MMS on iPhone OS 3.0 - iPhone Hacks
    09-25-2009 01:51 PM
  3. Minhala's Avatar
    Gotta say....I don't care if I never have MMS so still no reason for me to lose my JB. And while I only tether on very rare occasions, usually those are the times I really need it, so I would be sorry to lose it. But hopefully they come up with a jailbreak for 3.1 soon....
    09-25-2009 02:04 PM
  4. allabout17's Avatar
    Yeah I don't plan on updating to 3.1 until there is a way to jailbreak it. I love having a jailbroken iPhone!! I love the freedom and the programs not available in the app store. I don't really care that much about mms, but it would be nice to have the ability to do it, assuming I don't have to lose my jailbreak.
    09-25-2009 02:06 PM
  5. LVCIFER's Avatar
    Install the "Sinful" repo to Cydia. Download "MMS & Tethering Settings". Follow the instructions. And voil. You now have MMS after rebooting, ON 3.0.
    09-25-2009 02:15 PM
  6. futurecode's Avatar
    You don't need to have 3.1 for the "official" carrier update. Itunes just "automatically" makes you update to 3.1 before it'll let you automatically update the carrier settings.

    I'm here at work and we have 3 iphones. One 3G with a 3.1 Jailbreak, and two 3.0 Jailbreaks (a 3G and a 3Gs). I tried to plug my phone (the 3Gs) in all morning with nothing but the standard "there is a new {3.1} update for your iPhone" message. I took the Jailbroken 3.1 3G and plugged that in and got the carrier update message and updated it's carrier. Then I Plugged in the 3.0 3G and 3Gs and "hold shift and hit update" to manually select the official at&t carrier file that itunes downloaded a second earlier and updated both J/B 3.0's.

    So it works for both 3.1 and 3.0, just need to force the carrier update.
    09-25-2009 02:24 PM
  7. epphllps's Avatar
    If you dont want to upgrade to 3.1 here is the Apple link to the carrier file 5.5: http://appldnld.apple.com.edgesuite....h5/ATT_US.ipcc
    09-25-2009 02:40 PM
  8. bergman's Avatar
    Cool...now how do we use the carrier file in the link posted by epphllps?
    09-25-2009 02:43 PM
  9. futurecode's Avatar
    First,

    1. Open Command Prompt (windows: its in Program Files -> Accessories).

    2. Copy and paste the following command and press enter:
    cd C:\Program Files\iTunes\

    If youre using a 64-bit operating system use the following command instead and press enter:
    cd C:\Program Files (x86)\iTunes\

    3. Copy and paste the following command in Command Prompt and press enter:
    iTunes.exe /setPrefInt carrier-testing 1

    4. For the the new offical carrier file 5.5 use the link epphllps provided above or
    If you have donwloaded the new offical carrier file 5.5 then file is located in (windows):
    C:\Documents and Settings\[username]\AppData\Roaming\Apple Computer\iTunes\iPhone Carrier Support\

    5. And when you shift + update, look over on the lower right for the file type you want to be seen, it should give you the option to select wither an ipsw or a ipcc.

    6. Choose the new offical at&t .ipcc and restart when done.
    09-25-2009 02:47 PM
  10. cmatt's Avatar
    Install the "Sinful" repo to Cydia. Download "MMS & Tethering Settings". Follow the instructions. And voil. You now have MMS after rebooting, ON 3.0.
    I installed "Sinful" several days ago and just waited for today and, once AT&T turned the switch, my MMS has been working - jailbroken 3GS with 3.0.1 and AT&T 4.0 carrier file. Not sure why it works since I don't have 5.5 seems OK.
    09-25-2009 03:11 PM
  11. excberry's Avatar
    after doing this in the cmd prompt, nothing pops up. does it take this long for itunes to pop up?
    09-25-2009 03:18 PM
  12. futurecode's Avatar
    nothing will pop up, it'll just give you the ability to select a ipcc file when you do shift + update in itunes. At least that is what it did for me.
    09-25-2009 03:22 PM
  13. bergman's Avatar
    The solution from futurecode worked great. thanks!
    09-25-2009 03:36 PM
  14. galactica2001's Avatar
    OK, so I installed the sinful mms and tethering hack today because I tried to play nice and let AT&T roll out their update. But when I saw the original post saying you needed to have 3.1 OS to use MMS I went ahead and instaled the hack.

    My question now is, is here any point in me using th steps above to load the new carrier file? I know overall the hack is probably better since it provides tethering. I am just curious if I should do both or continue with my **** you AT&T I tried to play nice attitude.

    I have a jailbroken iPhone 3G 16gig running the 3.0.1 OS. The sinful hack worked great and I have not experienced the voice mail bug "yet".
    09-25-2009 03:36 PM
  15. Bull's Avatar
    May sound like a stupid question, but what is the difference between the 5.1 carrier file and the 5.5? I downloaded the 5.1 file from a Google search last week and yes my MMS is working as of today. What will happen when I sync and do the upgrade with iTunes this evening? I am running 3.1 now on a 32gig phone.
    09-25-2009 03:41 PM
  16. SOV's Avatar
    yeah i selected it, the photo icon in sms worked, but when i go to send the photo it never sends, does the other iphone im sending it to have to have the update aswell?

    lmao i would assume so, i had to sound like a retard for even asking that right?
    09-25-2009 03:42 PM
  17. Matt74's Avatar
    If you dont want to upgrade to 3.1 here is the Apple link to the carrier file 5.5: http://appldnld.apple.com.edgesuite....h5/ATT_US.ipcc
    Thanks for the link! While I already had MMS on my 3GS 3.0 iPhone, I thought it would be nice to have an up-to-date carrier file. I installed this update just fine with a shift-click. I was able to verify that I'm at version 5.5 by ssh'ing into my phone and checking the /private/var/mobile/Library/Carrier Bundles/ATT_US.bundle/version.plist file.
    09-25-2009 03:44 PM
  18. Matt74's Avatar
    yeah i selected it, the photo icon in sms worked, but when i go to send the photo it never sends, does the other iphone im sending it to have to have the update aswell?

    lmao i would assume so, i had to sound like a retard for even asking that right?
    Yes, if the other iPhone does not have the carrier update installed, the MMS will not go through. You will not get an error either.
    09-25-2009 03:45 PM
  19. vexvegaz's Avatar
    need some help guys..i tried sending a test mms but it hangs during send. both iphones have been updated BTW
    heres a ss of the error


    EDIT: cant post images until post count reaches 10
    09-25-2009 03:55 PM
  20. SOV's Avatar
    i updated my phone and my gf's and neither one of ours will send or recieve. so idk
    09-25-2009 04:18 PM
  21. excberry's Avatar
    i have a jailbroken iphone 3GS 3.0. download the file from post 7.

    works like a charm!
    Last edited by exciPhone; 09-25-2009 at 04:28 PM.
    09-25-2009 04:25 PM
  22. j00w00t's Avatar
    09-25-2009 04:47 PM
  23. redbeard's Avatar
    I did all that exactly, two times now, nothing changes for me at all, still stuck on 4.0, I'm using a pc and have a 3G.

    Edit:

    Working fine now, stupid computer wasn't selecting the carrier file..:o
    Last edited by redbeard; 09-25-2009 at 05:08 PM.
    09-25-2009 04:53 PM
  24. caleb22's Avatar
    Thanks futurecode! Works great!
    09-25-2009 05:11 PM
  25. PhiPhone's Avatar
    LVCIFER, do you happen to have the address for the sinful repo so I can add it to Cydia and apply your MMS solution? Thanks, much appreciated.
    09-25-2009 05:14 PM
43 12
LINK TO POST COPIED TO CLIPBOARD