1. garrett490's Avatar
    Hey if i update my iphone with whatever will allow me to send/receive mms today will it mess up anything? I have a 3G running version 3.0.
    09-25-2009 10:49 AM
  2. flyingember's Avatar
    what is "whatever"
    09-25-2009 11:29 AM
  3. dragonc12's Avatar
    If you download any updates from iTunes you WILL break your jailbreak...
    09-25-2009 12:19 PM
  4. Ipheuria's Avatar
    If he's talking about the carrier update it shouldn't do anything to your JB. In Canada we received the carrier update months ago, I was on 3.0 JB at the time, I did the update and nothing was changed in regards to the JB. The update is just for certain settings and not the whole OS.
    09-25-2009 01:18 PM
  5. flyingember's Avatar
    If he's talking about the carrier update it shouldn't do anything to your JB. In Canada we received the carrier update months ago, I was on 3.0 JB at the time, I did the update and nothing was changed in regards to the JB. The update is just for certain settings and not the whole OS.
    it's now been proven the update requires 3.1
    09-25-2009 02:18 PM
  6. LVCIFER's Avatar
    Yes, but in the US, the MMS carrier update requires the new version of iTunes and version 3.1, so those of us on the 3G[s] will have to find alternate means.

    I'm on 3.0, and got the Sinful MMS & Tethering package to work flawlessly on 3.0.
    09-25-2009 02:21 PM
  7. futurecode's Avatar
    You don't need to have 3.1 for the "official" carrier update. Itunes just "automatically" makes you update to 3.1 before it'll let you automatically update the carrier settings.

    I'm here at work and we have 3 iphones. One 3G with a 3.1 Jailbreak, and two 3.0 Jailbreaks (a 3G and a 3Gs). I tried to plug my phone (the 3Gs) in all morning with nothing but the standard "there is a new {3.1} update for your iPhone" message. I took the Jailbroken 3.1 3G and plugged that in and got the carrier update message and updated it's carrier. Then I Plugged in the 3.0 3G and 3Gs and "hold shift and hit update" to manually select the official at&t carrier file that itunes downloaded a second earlier and updated both J/B 3.0's.

    So it works for both 3.1 and 3.0, just need to force the carrier update.
    09-25-2009 02:29 PM
  8. excberry's Avatar
    You don't need to have 3.1 for the "official" carrier update. Itunes just "automatically" makes you update to 3.1 before it'll let you automatically update the carrier settings.

    I'm here at work and we have 3 iphones. One 3G with a 3.1 Jailbreak, and two 3.0 Jailbreaks (a 3G and a 3Gs). I tried to plug my phone (the 3Gs) in all morning with nothing but the standard "there is a new {3.1} update for your iPhone" message. I took the Jailbroken 3.1 3G and plugged that in and got the carrier update message and updated it's carrier. Then I Plugged in the 3.0 3G and 3Gs and "hold shift and hit update" to manually select the official at&t carrier file that itunes downloaded a second earlier and updated both J/B 3.0's.

    So it works for both 3.1 and 3.0, just need to force the carrier update.
    can you please detail these steps? when i hold shift and update, it asks me to point to a ipsw, but no carrier file.
    09-25-2009 02:38 PM
  9. epphllps's Avatar
    If you dont want to upgrade to 3.1 here is the Apple link to the carrier file 5.5: http://appldnld.apple.com.edgesuite....h5/ATT_US.ipcc
    09-25-2009 02:39 PM
  10. futurecode's Avatar
    First,

    1. Open Command Prompt (windows: its in Program Files -> Accessories).

    2. Copy and paste the following command and press enter:
    cd C:\Program Files\iTunes\

    If youre using a 64-bit operating system use the following command instead and press enter:
    cd C:\Program Files (x86)\iTunes\

    3. Copy and paste the following command in Command Prompt and press enter:
    iTunes.exe /setPrefInt carrier-testing 1

    4. For the the new offical carrier file 5.5 use the link epphllps provided above or
    If you have donwloaded the new offical carrier file 5.5 then file is located in (windows):
    C:\Documents and Settings\[username]\AppData\Roaming\Apple Computer\iTunes\iPhone Carrier Support\

    5. And when you shift + update, look over on the lower right for the file type you want to be seen, it should give you the option to select wither an ipsw or a ipcc.

    6. Choose the new offical .ipcc and restart when done.
    Last edited by futurecode; 09-25-2009 at 02:49 PM.
    09-25-2009 02:43 PM
  11. nextjeter2's Avatar
    im on a mac do u no how 2 do it on a mac
    09-25-2009 04:00 PM
  12. futurecode's Avatar
    im on a mac do u no how 2 do it on a mac
    Not 100 percent on this as I don't have a mac handy at the moment but I'm pretty sure this will work.

    Close iTunes
    Save the AT&T Carrier Settings File on your Desktop
    Open the terminal.app on your Mac which you can find in Applications/Utilities
    Copy/Paste into the terminal.app the following command:
    defaults write com.apple.iTunes carrier-testing -bool TRUE
    Close terminal
    Open iTunes
    Plug your iPhone into your Mac
    Select your iPhone inside iTunes in the sidebar
    Press and keep the Option-Key hold while clicking on Check for Update
    Now select the AT&T Carrier Settings File on your Desktop and hit Choose
    Let iTunes install the AT&T Carrier Settings File
    After installing unplug your iPhone and restart your iPhone
    09-25-2009 04:06 PM
  13. nextjeter2's Avatar
    u da man!!!!!! thnk u so much worked like a charm
    09-25-2009 04:12 PM
  14. Ipheuria's Avatar
    You don't need to have 3.1 for the "official" carrier update. Itunes just "automatically" makes you update to 3.1 before it'll let you automatically update the carrier settings.

    I'm here at work and we have 3 iphones. One 3G with a 3.1 Jailbreak, and two 3.0 Jailbreaks (a 3G and a 3Gs). I tried to plug my phone (the 3Gs) in all morning with nothing but the standard "there is a new {3.1} update for your iPhone" message. I took the Jailbroken 3.1 3G and plugged that in and got the carrier update message and updated it's carrier. Then I Plugged in the 3.0 3G and 3Gs and "hold shift and hit update" to manually select the official at&t carrier file that itunes downloaded a second earlier and updated both J/B 3.0's.

    So it works for both 3.1 and 3.0, just need to force the carrier update.
    I don't know if it's because your carrier update was released after 3.1, if there is a difference between US and Canada, because the difference between 3.0 and 3.0.1 was a minor change? or perhaps there's a difference between 3G and 3Gs? when our carrier update was released I was on 3.0 and 3.0.1 was the latest firmware at that time. It didn't force me to update the firmware in order to update the carrier file. It just asked if I wanted to update the carrier file I did and all was good with the world.
    09-25-2009 04:21 PM
  15. Mikeluv43's Avatar
    iTunes gives me some kind of error when i try to update the file.
    I'm using a 3GS with Firmware 3.0 Jailbroken and iTunes 9.0.
    09-25-2009 04:57 PM
  16. mcdan333#AC's Avatar
    iTunes gives me some kind of error when i try to update the file.
    I'm using a 3GS with Firmware 3.0 Jailbroken and iTunes 9.0.
    If you have "AT&T Carrier Logo" (or maybe some other carrier logo package?) installed in Cydia, remove it, then reboot, then try again with iTunes. That's what worked for me.
    09-25-2009 05:00 PM
  17. Mikeluv43's Avatar
    If you have "AT&T Carrier Logo" (or maybe some other carrier logo package?) installed in Cydia, remove it, then reboot, then try again with iTunes. That's what worked for me.

    Thanks for the heads up gonna make sure my carrier logo is not on.
    09-25-2009 05:26 PM
  18. Mikeluv43's Avatar
    I just updated to 5.0 Carrier and put in the correct settings and i now have tethering and MMS is enabled.
    09-25-2009 05:35 PM
  19. DJHus#IM's Avatar
    Thanx, Futurecode, it worked like a charm.
    09-25-2009 07:11 PM
  20. iphone4idiots's Avatar
    I tried to download the link given earlier in this thread and its a folder called payload with a file ATT US.bundle. I can't select it? Shouldn't be an ipsw file??

    I have a 3G jailbroken with 3.0. I installed the SINFUL package file and I can see the camera but I can't send or receive cause I'm on 4.0 carrier settings.

    Can someone give me a link to 5.0 or 5.5 so I can get this working or do I need to undo the SINFULL thing??

    Thanks in advance
    09-25-2009 08:19 PM
  21. iphone4idiots's Avatar
    OK, I'm on 5.5 now (needed to use Firefox to download) but its still not working.

    iPhone 3G jailbroken on 3.0 with 5.5 carrier. What's the problem?? I have the camera icon and attach photo, but it won't go. I installed the SINFUL package earlier today.

    Any ideas???
    09-25-2009 09:05 PM
  22. fridayxiii's Avatar
    OK, I'm on 5.5 now (needed to use Firefox to download) but its still not working.

    iPhone 3G jailbroken on 3.0 with 5.5 carrier. What's the problem?? I have the camera icon and attach photo, but it won't go. I installed the SINFUL package earlier today.

    Any ideas???
    Did you update your carrier file thru iTunes w/the key combo to manually select the file? The reason I ask is that the first page of the tutorial thread states that before using MMS & Tethering Settings, that you should uninstall any other hacks Sinful suggested. I can't say if he's also referring to the pre-release carrier file updates or not, but it's a thought.

    I have a JB 3GS on 3.0.1, installed the Sinful package, and life's good. Hope you get yours working too!
    09-25-2009 10:38 PM
  23. iphone4idiots's Avatar
    Yes, I manually did it. I guess I'll remove sinful and try the carrier file again. This sucks. It's funny - when I try and send it takes about 90 seconds before it bombs out.
    09-25-2009 10:42 PM
  24. badphoneguy's Avatar
    it seems there can always be just a bit more for me. but today they made a breakthrough and im happy for a while. :o)
    09-25-2009 10:53 PM
  25. iNakamura's Avatar
    epp and futurecode

    thanks a lot...it did the trick
    09-26-2009 01:35 AM
26 12
LINK TO POST COPIED TO CLIPBOARD