1. Bombsquad6116's Avatar
    Well, Im sure that Im not alone when I say this, but the only real incentive I had to update to 3.1, was MMS. And when I heard it wasnt on the update, I decided to wait to update so I dont lose my Jailbreak and all the sweet kickass things along with it for no reason. But, last night, i was reading online somewhere about The SinfulIphones way of getting mms, and it works! I have sent and received pictures and have not had a problem with it. And it was by far the easiest way to get it. All you have to do is go to Cydia, add the source repo.sinfuliphone.com/ . and once done, look for the app MMS and tethering settings. Install and then reset your network settings. It explains how on the description of the app.

    Hope it works for everyone else like it has for me.
    09-17-2009 05:25 PM
  2. fridayxiii's Avatar
    Some on AT&T have gotten it work, some haven't. Consider yourself among the fortunate. Many (including myself) have tried, but no joy.
    Last edited by fridayxiii; 09-17-2009 at 05:34 PM.
    09-17-2009 05:31 PM
  3. philatangy's Avatar
    I might just try this...
    09-17-2009 07:03 PM
  4. SaberSerene's Avatar
    I try this when I was on 3.0.1 and it didn't work. My iPhone was jailbroken with redsn0w and yes I added the source to Cydia and added the correct apn settings rebooted iPhone 3G and there was the camera icon in Messages and all but my pictures failed to send. I updated my carrier too, 5.1 now
    09-17-2009 11:27 PM
  5. Dionte's Avatar
    The camera icon finally showed up again, but no pic would send
    09-18-2009 12:04 AM
  6. LVCIFER's Avatar
    Here's why it suddenly works.

    As 9/25 comes nearer, AT&T has been removing the opt-out codes from all iPhone accounts.

    Simply put, AT&T has been flipping the "on" switch on our MMS service by location.

    If you tried the sinful method (like I did) a month ago, it didn't work. I tried it again last week, and suddenly it does. It's that simple.

    Trust me, it works. But you also have to live in an area that AT&T has turned "on".
    09-18-2009 02:40 AM
  7. capnben's Avatar
    I just tried this on my iPhone 3GS. It did not work for me. I live in Northern Michigan so maybe they have not turned it on for my account yet (like Lvcifer said) because I live in the boonies. Will try again next week.

    Capnben
    09-18-2009 02:54 AM
  8. philatangy's Avatar
    It's so interesting - My MMS is now working, thanks for the heads up! However, my coworker (who sits next to me) cannot get his to send or receive. It has the camera icon and he can select pictures, it just never sends. He still receives MMS as a link too.
    09-18-2009 12:50 PM
  9. DaPeeps's Avatar
    I and my two roommates all have 3GS's. My roomies girlfriend has a 3G. We are all in Oklahoma City. We all have had our MMS working for about a week now....we didnt used the sinful thing.....we just downloaded the 5.0 carrier file floating around and input the MMS settings....and thats all it took.
    09-19-2009 08:14 AM
  10. philatangy's Avatar
    I and my two roommates all have 3GS's. My roomies girlfriend has a 3G. We are all in Oklahoma City. We all have had our MMS working for about a week now....we didnt used the sinful thing.....we just downloaded the 5.0 carrier file floating around and input the MMS settings....and thats all it took.
    Could you give a quick explanation of how to do this?
    09-19-2009 02:55 PM
  11. Maggard's Avatar
    Eh, tried this and mine's still locked down. Nuts.
    09-19-2009 06:09 PM
  12. DaPeeps's Avatar
    Could you give a quick explanation of how to do this?
    Check out this link...it has the file needed and instructions

    How to Enable MMS (picture messaging) on Your iPhone (AT&T) [UPDATED x2] | Apple iPhone School
    09-20-2009 09:49 AM
  13. rmracer27's Avatar
    On at&t had my tethering working and now after doing this I lost it. Don't even see the option for it. What did I do wrong?
    09-21-2009 03:35 PM
  14. erauno's Avatar
    it worked. im sending pictures with no problem. it was quite easy too..i didnt have to change my apn settings.

    im running os 3.0.1 jailbroken on a 3g
    09-21-2009 05:11 PM
  15. erauno's Avatar
    the sinful hack worked for me that is. if theyre turning on due to location im located in Raleigh, NC.
    09-21-2009 05:12 PM
  16. philatangy's Avatar
    On at&t had my tethering working and now after doing this I lost it. Don't even see the option for it. What did I do wrong?
    I lost my tethering too!
    09-21-2009 05:27 PM
LINK TO POST COPIED TO CLIPBOARD