1. crashwins's Avatar
    Hello all

    I'm new to forums (just got my first iPhone yesterday). So, I jailbroke my Touch no problem this summer. After getting my iPhone, it took me about an hour to get the same done (I realized I had the wrong firmware, which was keeping me in the "waiting to reboot" mode awhile). But, I was successful, and the phone is jailbroken -- cydia, sbsettings, the whole 9. The kicker is: I get no service with my SIM (I'm an ATT user). I had read before putting my SIM in that some people were having issues staying off 3G and EDGE despite bossprefs and sbsettings (thereby racking up huge bills -- I don't want data, just wifi and texting) so I decided to visit my buddy at ATT (a manager) and have him totally disable EDGE and 3G for my whole family plan. Right when I left the store (before I put in my SIM in the iPhone and was using a crappy Pantech) I noticed there was no more "E" on my phone. I'm wondering, why am I not getting service? Do I need to unlock the phone now? Does the fact that I had him do this prevent me from using the iPhone because it needs some communication with EDGE or 3G? Anyway, any help would be appreciated. Thanks a lot for reading -- just want to join the club. Here are my specs (below)

    iPhone 3G 8GB
    FW: 3.0 (7A341)
    Jailbroke with redsnow 7.2
    09-11-2009 10:40 AM
  2. galactica2001's Avatar
    I might be wrong and I am sure these guys will correct me if I am, but I think the methods of connecting with the phone are Edge and then 3G if available. I think if you disable Edge and 3G then you effectively disabled all cell service. You could use your phone over WiFi if it is JB and has a VoIP app installed.
    09-11-2009 10:49 AM
  3. crashwins's Avatar
    Yeah, maybe so. But many people use their iPhones without Data plans. They just use texting, etc. Isn't using EDGE part of using this Data plan? I know there is a way for me to use my iPhone with ATT as a normal phone without paying for a data plan. I think turning off EDGE and 3G screwed that up, but isn't that effectively the same as when people turn these off in sbsettings or bossprefs?
    09-11-2009 11:21 AM
  4. galactica2001's Avatar
    The E stands for Edge at the top of your phone. Do you have Cell bars showing a cellular connection?


    3G Network:

    h t t p://s17.photobucket.com/albums/b59/Galactica2001/?action=view&current=3GNetork.jpg

    Basic Cell Only:

    h t t p://s17.photobucket.com/albums/b59/Galactica2001/?action=view&current=BasicCellOnly.jpg

    Edge Network:

    h t t p://s17.photobucket.com/albums/b59/Galactica2001/?action=view&current=EdgeNetwork.jpg
    09-11-2009 12:03 PM
  5. crashwins's Avatar
    All I'm seeing is about 1 bar (basic cell -- No "E" and no "3G") and then it fizzles into "No Service." So, yeah, no EDGE and no 3G...hmm. Any thoughts there? Thanks a lot
    09-11-2009 12:09 PM
  6. crashwins's Avatar
    Also, I have no EDGE or "E" on my current phone since I asked ATT to disable it. Just to be clear: I had my friend at ATT do this (maybe he doesn't know anything about iPhones) so I could never be charged internet fees related to the iPhone
    09-11-2009 12:10 PM
  7. galactica2001's Avatar
    I am thinking that you are failing to authenticate with the cell network. When I connect to a cell network from No Service it shows the ._ _ _ and then goes to the basic cell bars and after that it will go to either E or 3G (In your case you just are looking for it to get to the basic cell bars). To see if you are connecting at all you can go under Settings > General > About and see if your carrier is entered. If it is not then the phone was never set up in the store to be on the carrier's network. Also under Settings > General > Usage you can see if you are sending and receiving packets from the Cell Network. The last place to check is the obvious under Settings > Phone and make sure the "My Number" setting is entered.
    09-11-2009 12:30 PM
  8. crashwins's Avatar
    Ah ok. Well it was at one point set up to be on the ATT network. The guy I bought it from (his number came up in iTunes) used it for a week or so. But, when I JB it I effectively erased all that. The serial for this phone should be recognized by ATT though (if that's how they do it). Is there a way to go and re-activate the phone outside of using ATT? Because the phone was used on ATT at one point, I'm guessing it's because I disabled EDGE. I'm thinking the iPhone uses EDGE for making calls, but doesn't necessarily have to use it for downloading internet stuff. I'll check out what you said now. Thanks
    09-11-2009 01:27 PM
  9. Ipheuria's Avatar
    The phone doesn't use Edge or 3G to make calls that is for the data, emails, internet, etc. I had a 1st gen Iphone when Iphones weren't in Canada so therefore no data plans. The first thing that was done was JB and Unlock and I turned off the Edge. When I got my 3G I didn't need to unlock it but I still didn't have or wanted a data plan so I JB and turned off Edge and 3G. So both of my phones work perfectly without them enabled. So I would say search on info of restoring the phone and Jailbreaking/unlocking. Get all the info and youtube videos so you know what you're doing and have the programs and start from scratch because the JB/Unlock may not be working properly. Also once you're JB you can get SBSettings and you can turn off Edge and 3G.
    09-11-2009 02:02 PM
  10. crashwins's Avatar
    Thanks. That's helpful. I'll look into reJBing it. I already turned off EDGE and 3G, though, by having ATT do it manually for me -- that way I could never accidentally download something I get any internet use I was unaware of. I guess the problem is that my phone might not be setup for any number so it doesn't know how to communicate with ATT towers. Is this possible?
    09-11-2009 02:38 PM
  11. Ipheuria's Avatar
    I'm not quite sure why your phone has no reception but I would suggest starting from scratch just to see if the problem was your jailbreak.

    I just re-read your original post. OK so you're an AT&T user so you don't need to unlock the phone to have it working. The only time the phone uses 3G/Edge is App Store, Internet, Email, Location Services(ie. Camera app wants to use your location). I'm not fully sure of the last one hopefully someone will correct that if I'm wrong. Anyway what I think is you should restore the phone to get rid of the JB. Then go into settings and set Push to Manual. Make sure there is no email setup on the phone. When the phone is in your pocket you should have it locked so it wouldn't accidentally go on the Internet, App Store, etc. Then use the phone with your AT&T to see if you get reception before you JB. If you do then you know the phone is fine and it was possibly your JB. So get all the info,files and software you need and re-JB with the correct firmware. If it doesn't have reception when it's restored new without the JB then there's a prob with the phone and you can do whatever you can to have it replaced.
    Last edited by Ipheuria; 09-13-2009 at 08:28 AM.
    09-13-2009 08:15 AM
LINK TO POST COPIED TO CLIPBOARD