1. stoyanmar's Avatar

    I am dealing with a very odd problem - my wife's iPhone (locked iPhone 3G to AT&T with 3.0 & 3.0.1 firmware) does not connect to ANY wireless network. Mine (another iPhone 3G, but unrestricted one) connects with no problems whatsoever.

    In order to limit variables, I did verify and confirmed the following:
    1. Wi-Fi password is correctly entered (my own iPhone works fine with the same one)
    2. Wi-Fi signal is just fine (3 m away from the router)
    3. No MAC address filtering
    4. Fails both on WEP and WPA encrypted networks (the other iPhone works fine on both)
    5. Behaves the same way on different networks and router types - Dlink, LinkSys, 3Com.

    It actually see the Wi-Fi network but when I enter the password returns "Unable to join the network" as if the password was wrong or the router doesn't allow connection.

    What I tried (with little or no use):
    1. Reset Network Settings (total wrecking of the phone, endless booting)
    2. Erase All Content and Settings (wasted 2 hours and the final result is as above)
    3. 3.0 to 3.0.1 upgrade/jailbreak/unlock
    4. Different Regional Settings
    5. Airplane mode with Wi-Fi on - no improvement
    6. iPhone restarting

    Some details if needed:
    1. Jailbreak with redsn0w-win 0.8 (Cydia only), same behavior as with 0.72
    2. Unlock with ultrasn0w 0.91, but same behavior as with older versions of ultrasn0w

    The odd and ugly:
    1. BossPrefs says that Wi-Fi is OFF even though in Settings is appears as ON. If I turn it ON in BossPrefs, the next time I run BossPrefs it still shows as OFF...
    2. Reset Network Settings or Reset All Settings cause a total screw up of the phone - could be because of the jailbreak procedure, although I think I saw other jailbroken users to reset their settings with no problems...
    3. Yesterday, during the numerous Restore procedures (after the Reset Settings break-downs) the Wi-Fi was working sporadically (otherwise I would be unable to download and install ultrasn0w after the jailbreak), and after I Restore the phone stuff from iTunes's backup it stops working again...
    4. Even though it was working, it was still shaky, running once out of five attempts, at one point I thought I lost the phone - neither Wi-Fi nor modem working...

    A little history:
    I might be wrong but I think it stopped working after installing a rather expensive and bulky application named iGo My Way...
    However, I have to admit that the phone was not jailbroken properly last time (even before installing iGo) since I installed both Icy and Cydia, and later I was advised that I should not do this as there is a bug in redsnow that corrupts the partition if both are installed.

    This resulted in my inability to install anything from Cydia - I was getting an odd error message, ending with "probably a dependency cycle"... Anyway, at this time the Wi-Fi was working just fine until I installed the iGo (I believe)...

    A scream for help:
    Well, after spending almost 24 hours struggling with it, with no particular improvement, unless the above facts finding, I give up - and hope that anyone of you gurus can help with a bit of advice, if I didn't bore you to death with the above long text...

    Please, help! What could I be missing or failing??
    08-31-2009 11:17 AM
  2. sturamsden's Avatar
    I had a similar problem and it turns out it was my wifi router not my iPhone at all. I recommend going through your router settings too, maybe you'll be able to find the problem there. Reading through your list it seems you haven't done a Restore (through iTunes). Do that, see if it joins the wifi network before adding any extra apps, etc to it. Then jailbreak and test the wifi again.

    Let us know what happens.
    08-31-2009 12:19 PM
  3. Ipheuria's Avatar
    Do a search for "Wifi" ther were a bunch of threads with alot of other suggestions and info that may help you out.
    08-31-2009 04:43 PM
  4. stoyanmar's Avatar

    Thanks for the suggestions, I performed Restore (and even Update) in iTunes twice, but the phone gets locked because it is restricted to AT&T (and I haven't got a SIM card from it), so the wi-fi works until I unlock and restore from the backup (i.e. reinstall the apps, restore the phone book, etc.)...
    09-01-2009 03:29 AM
  5. surcal's Avatar
    iphone - unable to join the network - Solved

    Solved - Solved -Solved

    It seems that it could be a hardware problem.I held my iphone touching the antenna of WIFI router, it connected to the router. I was able to use the internet in this position only. Moving away from router's antenna, internet does not works. At leaset now I can do some very urgent works on iphone without GPRS connection.I was not able to use my wifi for last six months. Done everything that was already discussed in all the forums.I am calling it solved only because, I was afraid of future unlocks will not be possible without WIFI. Uptil 3.1.2 "iphone pcsuite" could be used to install ultrasn0w directly through PC. But from 3.1.3 iphone needs to install "AFC2ADD" through cydia, before it can be recognised as a jailbreaked iphone. Atleast WIFI working. This way I can update important cydia updates and apps without having to use GPRS.
    06-28-2010 09:43 AM