1. mceyedol's Avatar
    Right so I managed to update to 3.0 and jailbreak it using redsnow.

    I've loaded "Cydia" and it says there are some essential upgrades. I think okay lets upgrade....

    upgrades are for "Cydia Installer" & "Debian Packager"

    select upgrade on the installer and I get the following error in a little box:
    - Sub-process /usr/bin/dpkg returned an error code (2)

    The black screen with the dos style screen says:
    dpkg: pasre error, in file '/var/lib/dpkg/status' near
    line 26 package 'firmware'
    duplicate value for user-defined field 'Name'

    so I select okay. Try again and the same thing happens... can anyone help?

    I'm not able to install any cydia/icy progs at all...

    Any help would be great. Thanks Michael
    06-22-2009 10:28 AM
  2. MDT's Avatar
    I am wondering if you installed for Cydia and Icy
    I was getting the same error you were, but later (after installing some things thru/for Icy) started getting"

    "Couldn't configure pre-depend dpkg for ncurses, probably a depencency cycle."

    I am going to try to re-run redsnOw without Icy
    I'll repost with the result.
    06-22-2009 02:39 PM
  3. mceyedol's Avatar
    hi there,

    yes i did install redsn0w with "icy".... wonder if it was icy causing the problem? interested to find the results of yr experiment.

    thanks, michael
    06-22-2009 03:11 PM
  4. MDT's Avatar
    It worked for me.
    I got this idea from reading responses to other problems at another site.

    I simply ran redsnOw again, but didn't check to add Icy.
    when all was reloaded... Cydia works. and I still apear to have icy too.

    Hope this helped you.
    MDT

    EDIT: yes!!! I have SBSettings back.
    Thankyou to some user called MESS from the MACRUMORS forum
    and to all the guys who made redsnow and sbsettings and to the DEVteam
    Last edited by MDT; 06-22-2009 at 03:32 PM.
    06-22-2009 03:17 PM
  5. IamGov#IM's Avatar
    ICY is not supported on 3.0....In fact on my redsnow version ICY was not listed.
    06-22-2009 04:23 PM
  6. help#IM's Avatar
    its true, i just jailbroke and added ICY before, but i kept gettin the same error, so i did the jailbreak again in redsn0w and didnt choose to include ICY and now everything is workin fine
    06-22-2009 04:37 PM
  7. mceyedol's Avatar
    installing without icy seemed to fix it Thanks to everyone who's helped appreciate it. x
    Last edited by mceyedol; 06-23-2009 at 07:21 PM.
    06-23-2009 07:17 PM
  8. chrstphr.ross's Avatar
    I have an iPhone 3G on 3.0 running Cydia and Icy installers...i used the new Pwnage tool on my Mac though >.< never had a problem.
    06-24-2009 10:54 AM
  9. earl russell's Avatar
    The wait is over. The much awated unlock solution for iPhone 3G is now officially released by diligent iPhone Dev Team this week.

    Follow the steps for a quick setup, step by step procedure of how to unlock the iPhone 3G on Firmware 3.0.

    How to Download Ultrasnow just to Unlock iPhone 3G OS 3.0 | TechFlipper
    06-24-2009 01:49 PM
  10. irha's Avatar
    Just wanted to say thank you for the workaround. I also got cydia working by selecting only cydia while jailbreaking.
    06-25-2009 10:19 PM
  11. max_demon's Avatar
    Thank You So much it worked Flawlessly
    06-26-2009 02:54 PM
  12. bluesteelz's Avatar
    i dont like this 3.0 very much at but its too late now,main problem for me is that my favorite two apps are not working right...one v wallpaper...and ... two..mobilefinder. witch is what i use to copy new videos from mix tube. and then i install them into vwallpaper as my ring tones... can some tell me what i can do to fix this or if theres a patch for these apps thanks...
    06-26-2009 03:26 PM
  13. Ipodtouchfreak's Avatar
    I get the cydia error 2 all the time, but unlike you guys i never had Icy installed on my iPod touch, only cydia

    Can anyone help?
    09-05-2010 05:12 PM
  14. theringer's Avatar
    I get the cydia error 2 all the time, but unlike you guys i never had Icy installed on my iPod touch, only cydia

    Can anyone help?
    You could post your own thread instead of digging up (necroing) a 2 year old thread...
    09-05-2010 05:19 PM
LINK TO POST COPIED TO CLIPBOARD