1. Listy's Avatar
    The weird thing is when you call the phone, its ringing on the other end, but doesnt show up on the iPhone and it doesnt get diverted to my message bank. Which is what it would do, if the phone was out of service. I can make a call, receive and send text message and thats it. Its showing that Im connected to 3G, but Ive lost all internet on 2G as well. GPS works but it won't take you to the next location, as it need internet access. Connects to wireless and Im off and going with my internet again. Recently jailboke my phone, but it was fine. I really dont want to have to restore it all again. The other functions of the phone work fine and doesn't seem to have an other problems.

    Hardware or software ?


    Any ideas would be appreciated.
    Last edited by Listy; 04-17-2009 at 07:35 AM.
    04-17-2009 07:17 AM
  2. Jeremy's Avatar
    What firmware are you using?
    04-17-2009 09:15 PM
  3. Listy's Avatar
    2.2.1 Firmware. And as far as I can tell I'm getting calls when connected to wireless.
    04-17-2009 11:25 PM
  4. jaguar11's Avatar
    this happened to me before: it showed i was connected to att and 3g but internet didn't work... and after calling apple they told me to go to the att store. they didn't know what to do but they just tried disabling the data plan and enabling it again and it was fixed.
    hope this helps
    04-18-2009 11:34 AM
  5. Jeremy's Avatar
    The only time I had this issue was when I was using 3.0 and went back down to 2.2.1. When I went back to 3.0 the issue went away. Sorry, can't help you out.
    04-18-2009 02:04 PM
  6. Listy's Avatar
    The internet on the iPhone after a week and a half,
    decided to start work again for no apparent reason
    Had a meeting today with a few Optus guys and they
    said a few jailbroken phones had lost their internet.
    04-23-2009 04:34 PM
LINK TO POST COPIED TO CLIPBOARD