1. cjvitek's Avatar
    Okay, first off, I have jailbroken my phone previously. I then un-jailbroke it with a firmware update, and I decided to recently jailbreak again.

    I am running the newest firmware, 2.2.1 on Windows XP.

    I downloaded the software and the firmware from here. I go through the process, holding the home buttons down, power buttons down, etc as instructed (as I said, I have jailbroken before). Everything reports back as okay (I get the big "check" on the software, saying the pwnage process appears to have been successful, but then my iPhone is stuck in a continual reboot loop (with the little white apple logo). It is plugged in, reboots, the computer recognizes it, but then it reboots again (I never get to the home screen or anything like that).

    I *CAN* stop the reboot by booting in restore mode, and then restore a backup, but this is happening everytime I try to jailbreak my phone. Three different times.

    Any ideas? I am off to restore my phone again...GRRRR. >

    Chris
    03-03-2009 05:20 PM
  2. jamesus's Avatar
    This has happened to me before. I did a full restore as a new iPhone and then tried the jailbreak again.
    03-03-2009 05:33 PM
  3. cjvitek's Avatar
    Did you restore your phone from a backup, or literally leave it as a new phone completely? I restored from a backup.

    I supposed I could leave it as new and jailbreak, but then I will lose a lot of information (memoes, car logs, settings, etc)
    03-03-2009 05:38 PM
  4. jamesus's Avatar
    I always set it up as a new phone. Most of my data is synced on the cloud (notes, etc.), so I don't really lose much data except settings, etc.
    03-03-2009 05:47 PM
  5. cjvitek's Avatar
    Yeah, I have contacts, email, calendar in the "cloud", but some of the my apps have data that I will lose.

    Chris
    03-03-2009 05:49 PM
  6. jamesus's Avatar
    Yeah...you'll definitely lose that data then. Never fun...
    03-03-2009 05:51 PM
  7. cjvitek's Avatar
    Well, I will see what I can back up tonight maybe, and try a jailbreak from a clean restore.

    Chris
    03-03-2009 05:58 PM
  8. melwan's Avatar
    This restart loop will happen if you JB while having 3rd party apps on your phone.

    As jamesus said, restore it as anew phone, JB, then sync everything back on.

    Good luck
    03-03-2009 06:18 PM
  9. JustinHorn's Avatar
    Never tried JB'n, but could you just remove all the apps from the phone by doing a selective app sync and unchecking all of them? Then do a sync so all of them get removed.
    03-03-2009 06:47 PM
  10. cjvitek's Avatar
    If I recall, the first time I jailbroke I had 3rd party apps on the iphone. But maybe I just don't remember correctly.

    If you remove apps, you also remove the data for them. That was the problem.

    However, I just jailbroke right now, with 3rd party apps. AND all my data from a restore (so I can reinstall the apps as needed and the data from them will still be on the iphone!)


    I restored the iphone from a backup, then installed a couple of the apps (to try and copy the data). Things like Recorder and Car Care.

    I then expected to have to do a fresh restore, but I had copied the data so I could enter it again. But this time, when I jailbroke, it worked. I only have the three third party apps (car care, recorder, and dobot to dos). I wonder if the large number of apps I had was interfering previously?
    03-03-2009 06:50 PM
LINK TO POST COPIED TO CLIPBOARD