1. toubethao's Avatar
    i need help very bad. i tried jailbreaking my iphone 2g last night watching this video on youtube, doing everything he did, but it didn't turn out like his. my phone now shows the pineapple logo in a black screen and thats it. when i plug my phone into itunes, so i can try to restore it, itunes says that it does not recognize the phone. plz help!!! i'm desperate!!!
    02-14-2009 12:56 PM
  2. Jeremy's Avatar
    First do this, put it into recovery mode.

    Then restore as a new iPhone.

    Then follow TiPb's guide right here for Macs for the Jailbreak.

    Or

    Here of Windows.
    02-14-2009 06:47 PM
  3. kiwisholland's Avatar
    Does the 3G have to be restored as a new phone in itunes 8/Vista for this new 2.2.1 jailbreak deal to work?

    Can I just jailbreak my existing setup?

    Thanks
    02-17-2009 07:32 PM
  4. melwan's Avatar
    ^ if your existing setup is working, then yes you should be able to JB right away.
    02-17-2009 07:58 PM
  5. iCello's Avatar
    Hi, I've got a different problem with 2.2.1 jailbreaking. I have a iPhone 3G with 2.2.1 and a Macbook with 10.5.6 and when I try to follow the steps for Mac on this site to jailbreak my phone, I get to the step where it says Building IPSW and it just stays there, Ive left it there for an hour and nothing happens. Could someone help please? Before I read this I tried to do it without downloading the firmware and it found it from when I had updated to 2,2,1 and it did the same thing. So I tried downloading the firmware today and its still weird.
    02-21-2009 01:36 PM
  6. Jeremy's Avatar
    Hi, I've got a different problem with 2.2.1 jailbreaking. I have a iPhone 3G with 2.2.1 and a Macbook with 10.5.6 and when I try to follow the steps for Mac on this site to jailbreak my phone, I get to the step where it says Building IPSW and it just stays there, Ive left it there for an hour and nothing happens. Could someone help please? Before I read this I tried to do it without downloading the firmware and it found it from when I had updated to 2,2,1 and it did the same thing. So I tried downloading the firmware today and its still weird.
    It's your macbook that is giving you that trouble. More specifically the 10.5.6 update. A hub is your easiest fix.
    02-21-2009 01:39 PM
  7. ctt1wbw's Avatar
    Yep, it has to be a powered usb hub. I found that out the hard way, but it works now.
    02-21-2009 02:46 PM
  8. iCello's Avatar
    Thanx. I've been meaning to get a hub for a while anyway.
    02-21-2009 03:16 PM
  9. htc news's Avatar
    I tried like others to jailbreak 2.2 and got stuck at the hanging apple of death as obviously many others had. While I was reading through the numerous posts regaring solving the problem, about 20 minutes after the successful jailbreak and 3 to 4 reboots of the phone on its own. Then allof a sudden it booted in its newly modified state. Thank for distracting me so i didnt go throuh the 5 hour restore process again. I really love the site!!!
    06-01-2009 10:34 PM
LINK TO POST COPIED TO CLIPBOARD