1. iMore Question's Avatar
    Hey friends

    My iphone 4 *(3,2)* is stuck in recovery mode.

    I have downloaded ios 7.1.2 firmware (iPhone3,2_ 7.1.2_11D257_Restore.ipsw) and tried to restore it using itunes but every time i get **Error (2)** on itunes.

    My device is **NOT** jailbroken.

    I just wanted my iphone to be working again.

    I have tried all tools to get out of recovery but all failed
    **TinyUmbrella** is not working.
    **Redsn0w** doest not support ios 7.1.2
    tried **Recboot** , **Reiboot** no luck

    Please Help i have searching for this past two days but not able to restore my iphone.
    10-07-2015 06:42 AM
  2. kch50428's Avatar
    I have downloaded ios 7.1.2 firmware
    You can't restore to that firmware as Apple is no longer signing it. You can only restore to the last version of iOS that your device will support.
    10-07-2015 06:56 AM

Similar Threads

  1. Replies: 11
    Last Post: 10-08-2015, 06:37 PM
  2. Replies: 2
    Last Post: 10-08-2015, 04:50 PM
  3. I amNew to iPhone, a few questions
    By kygator13 in forum iPhone 6s Plus
    Replies: 6
    Last Post: 10-08-2015, 03:42 PM
  4. Is there a 3194 resolution fix?
    By kulpr33t in forum General Apple News & Discussion
    Replies: 1
    Last Post: 10-07-2015, 08:23 AM
  5. On my iPhone - security, how to separate org. and personal data ?
    By iMore Question in forum Business, Enterprise & Security Discussion
    Replies: 0
    Last Post: 10-07-2015, 04:53 AM