1. friskies64's Avatar
    I have recently just found out about Home Sharing and it sounded like a neat feature to be able to clear the music on my iPad 3 to regain space and also stream my movies, but I can't get it to work. On my computer (Windows 7 with latest iTunes), I have enabled home sharing and signed in with my Apple ID. On my iPad, I opened Settings went to Music/Videos and signed in with the same Apple ID (I only have one). When I open either Music or Videos on my iPad, I see nothing that would hint at sharing. No shared option in the "more" section of Music and only my iCloud purchases in videos. I have the same problem on my iPhone 4S as well. All devices are connected to the same wireless network. I've tried enabling and disabling "Share my library on my local network" and neither setting worked. I've also tried signing out of iTunes, de-authorizing, uninstalling, reinstalling, signing in, and finally reauthorizing with the same results. My web searches didn't find anything helpful either. What settings might I be missing to enable Home Sharing? Both the iPad and iPhone are on iOS 7.0.4.

    Thanks
    01-02-2014 03:08 PM
  2. dalaen's Avatar
    Hi Friskies!

    Is your computer running while you're checking on your iPad?
    For a PC, it must be running (and not idling), as far as I know.
    For a Mac, there's a "wake up through network" feature, allowing to share the library even with the lid closed.
    01-02-2014 04:00 PM
  3. friskies64's Avatar
    Yes, I have kept my computer running with iTunes open. Sleep mode is disabled so only the monitor turns off. When I tried to stream though, I haven't let the monitor go to sleep so I don't think this is the problem. I've removed and re-added iTunes to the firewall with no change either. I also have an old iPhone 3GS on 6.1.3 and couldn't get sharing to work on that either so I don't think it's related to iOS 7.
    01-02-2014 04:16 PM
  4. rayz336's Avatar
    Have you tried powering on and off your router?
    01-02-2014 04:26 PM
  5. friskies64's Avatar
    I have since our router is getting old and I need to restart it pretty often otherwise the TV and Internet don't work well. I've just ordered a new wireless N router that should arrive in a few days. I'll see after installing that if it was my router that was the issue. I don't think I'm doing anything wrong on my computer or iOS devices.


    Sent from my iPad using Tapatalk
    01-02-2014 07:36 PM
  6. rayz336's Avatar
    I have since our router is getting old and I need to restart it pretty often otherwise the TV and Internet don't work well. I've just ordered a new wireless N router that should arrive in a few days. I'll see after installing that if it was my router that was the issue. I don't think I'm doing anything wrong on my computer or iOS devices.


    Sent from my iPad using Tapatalk
    Yeah it sounds like the router, hopefully the new one fixes things.
    01-02-2014 11:54 PM
  7. friskies64's Avatar
    It turns out it wasn't my router that was giving me problems but rather the wireless bridge that connects my computer to the network. I had to disable "Filter Multicast" in the security settings (DD-WRT) on the bridge. After that my iPad saw my computer's library and can stream now.
    01-03-2014 10:26 PM
  8. rayz336's Avatar
    It turns out it wasn't my router that was giving me problems but rather the wireless bridge that connects my computer to the network. I had to disable "Filter Multicast" in the security settings (DD-WRT) on the bridge. After that my iPad saw my computer's library and can stream now.
    Ah ok, well I am glad you got it working!
    01-04-2014 10:37 AM
  9. dbienenf's Avatar
    I'm not a total rookie, but how do you "disable "Filter Multicast" in the security settings (DD-WRT) on the bridge?"
    08-19-2014 06:35 AM

Similar Threads

  1. Replies: 16
    Last Post: 04-28-2015, 07:14 AM
  2. Is there a way to delete a shared Apple ID and set up my own?
    By iMore Question in forum Ask a Question
    Replies: 2
    Last Post: 01-02-2014, 10:37 AM
LINK TO POST COPIED TO CLIPBOARD