1. anon(192806)'s Avatar
    So I updated all my stuff today.. Mavericks, iPhoto, iTunes, iOS 7.0.3, etc and when I try to sync my 5c to my Mac iTunes stops at the "Finishing Sync" step and hangs there. The phone doesn't indicate that a sync is still occurring (no twirling arrows near the top) but iTunes never finishes.

    Anyone else experiencing the same? Any known resolutions? Happens with my 4th gen iPad as well.
    10-22-2013 11:26 PM
  2. pkcable's Avatar
    Have you tried restarting the computer AND the phones/ipad
    10-23-2013 08:59 AM
  3. anon(192806)'s Avatar
    Yep. Tried that. Tried the basic troubleshooting. Even deleted all previous backups and started from scratch.

    I did notice that it doesn't happen when I disable syncing with iPhoto.
    10-23-2013 09:50 AM
  4. Just_Me_D's Avatar
    Several people have reported the same thing last night. I don't sync to iTunes, but I do back it up using iTunes and doing so is not a problem. If I come across a remedy, I'll be sure to update this thread.
    10-23-2013 09:52 AM
  5. jlundell's Avatar
    Same symptom here. However, if iPhoto (9.5) is active and I sync (my iPhone 5, 7.0.3) in iTunes via the Sync button, the finishing-sync message goes away. Though now iPhoto shows a "Loading" message that isn't going away. I haven't tried actually syncing a photo yet; I guess that's next
    10-23-2013 10:33 AM
  6. anon(192806)'s Avatar
    So you're saying if iPhoto is open, you have the issue but if it's closed you don't?
    10-23-2013 11:08 AM
  7. pkcable's Avatar
    Starting to sound like maybe this is a bug.
    10-23-2013 12:07 PM
  8. jlundell's Avatar
    I was having the problem without iPhoto open. I opened iPhoto, and the problem disappeared. Now I've closed iPhoto, and it's still gone.

    It may be relevant that I also have Xcode 5.0.1 installed, since it also communicates with the device.

    Subsequently I quit iPhoto & Xcode (still OK) and then restarted iTunes (now I see the problem). Then start iPhoto and do another iTunes sync (problem disappears).

    FWIW, I get a similar symptom with my iPad 2 running iOS 6.
    10-23-2013 12:09 PM
  9. anon(192806)'s Avatar
    Thanks for the feedback. Doesn't seem there is a definitive cause or solution.
    10-23-2013 12:29 PM
  10. Jaguarr40's Avatar
    Yes on this new version 11.1.2 which I just installed is what you are talking about happened to me twice so far. it just never finishes syncing after I updated several apps, 5 and then one I missed. I just unplugged the cable and everything was fine. i plugged back in and did a backup to be safe and that went fine. Hopefully if indeed it is iTunes I am sure it will be addressed shortly.
    10-23-2013 08:18 PM
  11. jmr1015's Avatar
    I had this issue today when syncing my 5S. I backed up manually and after the backup & sync process, the Finishing Sync finally stopped.
    10-23-2013 09:11 PM
  12. deedeebear's Avatar
    same thing here. don't know why it's stuck on 'finishing sync'
    10-27-2013 07:34 PM
  13. Jaguarr40's Avatar
    UPDATE: Just got off the phone an hour ago after updating 3 apps and then syncing them to my phone vie tether to iTunes. I did not want to unplug because they tell you not to and the only way i found was to right click on the device on the left side and select backup, that stops it but it is a pain so Applecare+ walked me through in a specific order 5 different components with iTunes to uninstall them from my PC using Windows 7 Pro. After that I reinstalled iTunes and problem resolved. I more than likely because of installing the night it came out a bad download. Now I am good to go.
    10-28-2013 04:31 PM
  14. cknycc's Avatar
    Select File > Device > Transfer Purchases from...

    This solved it for me.
    11-02-2013 10:31 AM
  15. estroh's Avatar
    Reinstalling iTunes and Transferring purchases, and "waiting it out" didn't stop it from happening again to me.
    11-03-2013 09:52 AM
  16. Redshirt's Avatar
    Yeah, seems to be a bug in the latest iTunes. You can click Sync again in Devices (and your device) and it'll sync again and usually finish.

    Not sure if anything negative happens from unplugging while it's stuck in that "syncing" step, but I've been avoiding finding out by clicking that sync button.
    11-03-2013 01:13 PM
  17. acerace113's Avatar
    ...Not sure if anything negative happens from unplugging while it's stuck in that "syncing" step...
    Yes when iTunes syncs it creates a temporary ghost file on the iOS device and if you unplug it or interrupt it that space is still taken up on the iOS device but iTunes will list it as under "other" when you connect back to iTunes. I've tested this a lot a year ago and those were my findings.

    Sent from my iPod touch (5th generation) or iPhone 4S (iPhone 5S coming soon) using Tapatalk.
    11-04-2013 01:02 PM
  18. Jaguarr40's Avatar
    My UPDATE: I thought I had my problem with resolved as i uninstalled iTunes and 4 other items that you have to remove in a certain order from your add-remove programs if on a Windows PC like me. I worked first time and since then it has reverted back so it is a known bug to us but does not seem to be with Apple. I called and spoke to their tech support and they swear they have not heard of it and told me how to delete and what order. Now to stop the sync I just right click on the iPhone on the left and choose backup where it stops the sync, does a backup and done. All apps are synced no problem so i suppose that is what I will do until the next version comes out.
    11-04-2013 07:38 PM
  19. TapperTalk's Avatar
    Select File > Device > Transfer Purchases from...

    This solved it for me as well.
    11-05-2013 07:20 AM

Similar Threads

  1. Replies: 3
    Last Post: 10-27-2013, 12:31 PM
  2. iOS 7 and Core Data Sync
    By impaler in forum iOS
    Replies: 1
    Last Post: 10-20-2013, 06:31 PM
  3. Replies: 3
    Last Post: 10-20-2013, 01:49 PM
  4. Replies: 3
    Last Post: 10-20-2013, 01:44 PM
  5. calandar sync iphone4 to google calendar
    By iMore Question in forum Ask a Question
    Replies: 1
    Last Post: 10-20-2013, 10:18 AM