1. spiderman001728's Avatar
    Anybody ever seen this? My phone works fine and I've had it about a week, tonight I noticed this.
    10-23-2011 11:37 PM
  2. Peligro911's Avatar
    Re activate your phone should make it appear


    Sent Into Orbit from my iPhone 4S using Tapatalk
    10-23-2011 11:57 PM
  3. spiderman001728's Avatar
    thanks but Ive had the phone over a week, and its been activated. Any other ideas?
    10-25-2011 05:21 PM
  4. Peligro911's Avatar
    Everything may work fine my phone did too .. I had a weird phone number issue and re doing the programming from the carrier solved it .. Other than that u can try a restore and see if it works then


    Sent Into Orbit from my iPhone 4S using Tapatalk
    spiderman001728 likes this.
    10-25-2011 10:08 PM
  5. spiderman001728's Avatar
    Magically it now displays my number. Don't know what the issue was but thanks for the suggestions.
    10-27-2011 02:20 PM
  6. bluelightalarm's Avatar
    I had this issue when I ported my number from my old network. I ejected the SIM and re-inserted it and it's all good now
    08-20-2012 07:46 AM
  7. Eileen89's Avatar
    The same thing happened to me on Saturday when I restored my 4S to remove my jailbreak. After it went through the entire process and rebooted my number in iTunes was just like your screenshot. My iPhone still worked fine so I unplugged it and left it alone. Last night when I plugged it into iTunes again to transfer a few new apps my number was there again in iTunes. Don't know what happened but I was glad that it appeared again.
    08-20-2012 07:56 AM
  8. ghostface147's Avatar
    I get that from time to time. Not too often and it doesn't seem to hurt anything. Usually a reboot of the computer fixes it for me. Or even a reboot of the phone.
    08-20-2012 05:39 PM
LINK TO POST COPIED TO CLIPBOARD