1. Issa's Avatar
    Here's the device spec i have

    iPhone 3Gs
    IOS 4.1
    Jailbroken
    Unlocked

    I have Win Vista
    iTunes 10.0.1.22

    The problem i'm facing today is in the title, but i would explain more in order to get the help i'm looking for.

    I backed up my iPhone before i upgraded it to 4.1
    Upgrade went just fine
    Jailbroken and Unlocking went fine as well.
    Phone is working with no problems.

    I got to the point where i want to restore the backup to get my pix, videos, contacts, etc.... back

    I got the error i wrote on the title.
    Searched the net for more than 4 hours, Tried every little advice i got
    Including but not limited to

    - first delete the old backup by choosing Preferences > Devices > Delete Backup. You should copy your old backup somewhere else before you do this. Your backup is stored in the Users/[username]/Library/Application Support/MobileSync/Backup folder on Mac, or C:\Documents and Settings\[username]\Application Data\Apple Computer\MobileSync\Backup on Windows.
    - Windows users may need to change their computers time zone to fix this issue.
    - Windows users may also need to kill the AppleMobileBackup.exe process and restart iTunes.
    - Windows users may also need to run iTunes as an administrator. Go to Computer>local disc (c>Program Files>iTunes>iTunes.exe then right click and run iTunes.exe as administrator.
    - Turned Firewall off.
    - Changed USB ports, and restarted the computer many times.

    I also tried to make new backup to see if my old backup went bad but i got new error which is -- iPhone couldn't back up iPhone "Issa" because a session couldn't be started with the iPhone--

    I'm really confused in what to do. i will appreciate any help i get from you guys.

    Thank you
    11-10-2010 07:15 AM
  2. Issa's Avatar
    89 Viewers no reply. Come on guys, I need help
    11-11-2010 09:04 AM
  3. mapcg18's Avatar
    hey im having the same exact problem, have you found anything that worked yet. thanks
    11-18-2010 08:48 PM
  4. stefano100's Avatar
    I am having the exact same issue!!

    Have tried everything as detailed above. Even been into the Apple Store, but to no avail.

    Would really appreciate a solution
    11-25-2010 12:08 PM
  5. Issa's Avatar
    I didn't get a fix yet, I downgraded the iOS to 3.1.2 and then upgraded it to 4.0.1 and that's what i have now.

    Sorry guys no fix for the problem
    12-10-2010 09:43 PM
  6. jack3dan's Avatar
    You have to erase your iTunes app and download/install it follow the directions of the following apple link.
    Disconnect your iPhone, iPad, or iPod from the Mac.
    In the Finder, locate iTunes in the Applications folder and drag it to the Trash.
    Move the iTunes icon to the Trash.
    Choose Go > Go to Folder.
    Enter /System/Library/Extensions and click Go.
    Locate the file AppleMobileDevice.kext and drag it to the Trash.
    Choose Go > Go to Folder.
    Enter /Library/Receipts/ and click Go.
    Locate the file AppleMobileDeviceSupport.pkg and drag it to the Trash. If prompted, authenticate with the administrator password.
    Note: This file may not be present in Mac OS X v10.6 and later; skip to the next step if this is the case.
    Restart the computer.
    Choose Finder > Empty Trash and restart the computer.
    Download and install the current version of iTunes.
    Connect your device to the Mac again and open iTunes
    05-01-2011 07:03 PM
LINK TO POST COPIED TO CLIPBOARD