1. nickgoodman1's Avatar
    I have my IPhone 4 but cannot connect up to my Mac at home - I pug it in and get the message 'The iPhone cannot be used because it needs ITunes version 9.2 or later. I have downloaded it (Plus it is definitely already on my Mac) but still get the message. i cannot find out where to check on the phone exactly which version it has installed - any ideas? Thanks
    07-03-2010 04:13 PM
  2. Duvi's Avatar
    Reboot both phone and mac. Also switch to the
    next USB port.
    07-03-2010 04:17 PM
  3. OTACORB's Avatar
    You may end up having to just uninstall iTunes and then reinstall it. I would do that if it continues beyond anything else you've tried.
    07-04-2010 12:24 AM
LINK TO POST COPIED TO CLIPBOARD