1. cadman33619's Avatar
    Hi All,

    i'm confused...trying to JB a 3Gs...updated to 4.0 ipsw with itunes but when i try to use redsnow to JB it does not recognize the 3Gs 4.0 ipsw. What am I doing wrong here?

    I'm pretty sure its a 3Gs bc I tried to use spirit to JB and it showed the devise as a 3Gs. (i learned afterward that i can't use spirit)

    i'm stuck in the "connect to itunes" logo so i cannot check my firmware version or bootrom. I can put it into DFU mode with no prob to load the ipsw in itunes.

    i've tried updating with the 3G ipsw in itunes...that loads ok but when i use redsnow i get stuck on the "waiting for reboot" screen. I've tried every method i can find to get past the reboot phase.

    any help would be great.

    07-01-2010 08:11 AM
  2. peanutgallery's Avatar
    was the iOS 4 ipsw custom? - meaning did you run it through sn0wbreeze or pwnagetool before you updated through itunes? If you used sn0wbreeze or pwnagetool before you updated then it should be jailbroken (if I'm not mistaken).

    as far as I know there currently isn't a jailbreak for a 3gs running a stock iOS 4 install. I think all methods of jailbreaking iOS 4 require a previously jailbroken 3gs running the old bootrom.

    if you can put it into DFU mode then you can check your bootrom fairly easily. I know because I did this last night.

    were you ever jailbroken before? is this your first attempt at jailbreaking? if you were jailbroken before are your shsh blobs on file?

    are you using a mac or a pc?

    the more information the better.
    07-01-2010 08:52 AM