1. driverm's Avatar
    Hi.
    I have a 3GS with 3.1.2 OS jailbroken and simlocked by blackra1n and blacksnow. 2 days ago, my iphone stuck at apple logo screen and restarting itself continuously. After many attempts with many solutions, and being unsuccessful at all, I decided to restore it with a custom firmware.

    I downloaded 3.1.3 firmware, and with sn0wbreez, I created the custom firmware. Now, I m trying to restore my iphone through itunes with the custom firmware.

    BUT now, I m getting errors which disables me to restore the iphone. I get itunes error (2) when my iphone is in recovery state and I get itunes error (1600) when it is in DFU state.

    Btw, after my first unsuccessful attempt for restoring with custom hardware, iphone doesnt stuck on apple logo, it immediately enters the recovery state, and stucks there..

    Please help me, I need my iPhone so much these days. As part of my job, I need to look at my mails while I am away too, but w/o my iphone, it really is impossible for me.

    This really is urgent! Please help me.

    Thanks alot.
    04-20-2010 09:32 AM
  2. big9erfan's Avatar
    Did you have a tethered jailbreak?
    04-20-2010 10:40 AM
  3. driverm's Avatar
    nope. Actually I could shut down and restart my iphone normally. Didnt need to jailbreak it everytime. So, i guess it was not tethered.
    04-20-2010 10:45 AM
  4. big9erfan's Avatar
    There's no need to create a second thread. That's just bad forum manners.

    The firmware you downloaded, are you sure it was for a 3GS and not a 3G? Also what version of iTunes are you using?
    04-21-2010 12:09 AM
  5. driverm's Avatar
    Yes I am very sure I downloaded the right firmware now.
    I m using itunes 9.

    btw, I thought the situation changed so wanted to create a new thread because of that. Sorry If I mistaken here..

    As I told at the other post, now the situation changed a bit. One of my friends createda new jpsw file for me and I tried to use that for my restore. If i try to connect my iphone with recovery state, then 99% seems to be finished but at the last minute, it gives error (6). The loading bar on the iphone was loaded like 99% before the error. I tried it at 2 PC's and 1 MAC and with 2 USB cables. Nothing changed!

    If I try to connect my iphone with DFU state, then i get error (1600) from the begining.
    04-21-2010 04:16 AM
  6. driverm's Avatar
    kk, sth magical happened right now. I wanted to use blackra1n if that would help me with this. So, started blackra1n at my mac, and saw that I wasnt able to see geohot's imagine now. I thought that was another problem, but I didnt touch anything and left it connected to mac... Then after an hour, I hear the sound from my iphone.. I is ON!

    But now, we have another problem It seems like, it isnt SIM unlocked. however, while creating the custom firmware, I m sure I wanted it to be SIM unlocked. But u know, the restore process had failed at 99% and gave error 6 while "restoring iphone firmware". So, maybe it is because of that... dont know...

    Oh, and, I can use every feature of the phone, just checked it, BUT cannot even get into the Networks settings at the Generals tab. when I click networks button, the settings menu stucks and then I have to press the home button to get out. When I press the settings button afterwards, it gets me to the main screen of the settings..

    Btw, btw, now i can give u baseband info. : 05:11:07

    Please help me we are on the final stage now

    THANKS ALOT
    04-21-2010 08:14 AM
  7. big9erfan's Avatar
    I'm not sure how to clear that up. I'd usually say you should try a restore, but with the problems you had you may not want to do that again. Lets see if anyone else has ideas.
    04-21-2010 12:23 PM
  8. driverm's Avatar
    Oh noooo... I tried to install blackra1n from cydia, and after install, iphone again stuck and restarted itself. Again, getting stuck at the apple logo... noooo...

    We couldnt successfully install the custom firmware, so it wasnt reliable however it was working for the first time this week. Again, I m experiencing error 6 at custom firmware install at the time 99% was finished.

    Anyone has any idea? Pleassseeee I am having so many problems at work just because I dont have my iphone working...

    Please help me..

    Thanks alot..
    04-21-2010 04:50 PM
  9. LVCIFER's Avatar
    Just to be clear, I'm the 'friend' who created the custom firmware (ipsw). I've been trying to help this dude for two straight days on both Twitter an AIM. This is without a doubt one of the most problematic cases I've worked on yet. If he goes into recovery mode and tried to retire to a custom firmware, he gets to 99% then gets error (2). If he goes into DFU mode to custom restore, then he gets the 1600/1601/1604 errors.

    His phone turned on before, literally by means on magic, but it wasn't unlocked.

    The poblem here is that he can't just restore because he NEEDS to be unlocked onto an 'unofficial' carrier.
    04-21-2010 06:07 PM
  10. LVCIFER's Avatar
    And to further clarify, when his phone supernaturally turned on, I told him to try to reinstall sn0w, to unlock it, but when it restarted/rebooted, it went RIGHT BACK into the f'n infinite boot loop.
    04-21-2010 06:09 PM
  11. big9erfan's Avatar
    Try using irecovery to get out of the boot loop?
    04-21-2010 06:20 PM
  12. LVCIFER's Avatar
    *chuckle* I believe that he did.... But I'll let him answer that one.
    04-21-2010 06:25 PM
LINK TO POST COPIED TO CLIPBOARD