1. scarm10's Avatar
    to fellow jailbreakers out there, Apple is cracking down on jailbreaks, they have blacklisted previous OS for the iphone and itouch. I called them, and what I learned was very important. The New Itunes 9.1 release is capable of detecting jailbreaks, and if apple executes it, it is also capable of bricking your itouch/iphone permanently, untill you update it to 3.1.3. Apple has digitally unsigned the old 3.1.2 or lower OS'es, so itunes will not use them. the only one you can use to update or restore now is 3.1.3. This is a sad day for software programmers. To all, DO NOT download itunes 9.1, and DO NOT update to 3.1.3. It is rediculous how apple is trying so hard to kill all jailbreaks, instead of putting new features into the ipod. BE CAREFUL!!! you can still sync your music with no worries if you have itunes 9.0 or lower. just do not update.
    04-02-2010 05:22 PM
  2. Mustang5Oh's Avatar
    I'm on a Macbook with iTunes 9.1 that I downloaded yesterday and just synced my JB 3.1.2 phone and all is working perfectly.
    04-02-2010 05:24 PM
  3. scarm10's Avatar
    I'm on a Macbook with iTunes 9.1 that I downloaded yesterday and just synced my JB 3.1.2 phone and all is working perfectly.
    As far as I know, apple hasn't executed itunes to brick anything yet, so we're lucky. I'm glad they haven't yet, because jailbreaking just makes things better. I tried to Jailbreak 3 touches this week, and none have worked, i get a message that says this ipod isn't eligible for the requested build. I told this to the techie guy at apple, and he told me everything. sucks
    04-02-2010 05:29 PM
  4. Mustang5Oh's Avatar
    meh I'll believe it when I see it happen. not calling you a liar but I don't see Apple doing that but only time will tell I guess.
    04-02-2010 05:30 PM
  5. scarm10's Avatar
    meh I'll believe it when I see it happen. not calling you a liar but I don't see Apple doing that but only time will tell I guess.
    True, I'm not taking offense. That would be very crappy if they did.
    04-02-2010 05:31 PM
  6. Mustang5Oh's Avatar
    maybe they should just take the hints offered from a JB and add the features that we all want and then people wouldnt want to or need to JB. thats a novel idea!!!
    04-02-2010 05:39 PM
  7. scarm10's Avatar
    maybe they should just take the hints offered from a JB and add the features that we all want and then people wouldnt want to or need to JB. thats a novel idea!!!
    No Kidding! lol, Especially the volume button tweak. it controls volume, switches songs, and play/pauses music. Friggin genius. lol. its all about the money sadly thats why almost all software for macs costs money. When you want to create a program for a mac, you have to pay apple to use what is the equivalent of microsoft c++ and pay for them to sign it, so you can actually install it on a mac.
    04-02-2010 05:44 PM
  8. big9erfan's Avatar
    to fellow jailbreakers out there, Apple is cracking down on jailbreaks, they have blacklisted previous OS for the iphone and itouch. I called them, and what I learned was very important. The New Itunes 9.1 release is capable of detecting jailbreaks, and if apple executes it, it is also capable of bricking your itouch/iphone permanently, untill you update it to 3.1.3. Apple has digitally unsigned the old 3.1.2 or lower OS'es, so itunes will not use them. the only one you can use to update or restore now is 3.1.3. This is a sad day for software programmers. To all, DO NOT download itunes 9.1, and DO NOT update to 3.1.3. It is rediculous how apple is trying so hard to kill all jailbreaks, instead of putting new features into the ipod. BE CAREFUL!!! you can still sync your music with no worries if you have itunes 9.0 or lower. just do not update.
    Not sure who you talked to, but they drink the Apple Kool-Aid just as much as anyone. ITunes isn't going to brick anything to force and update to a new OS, especially when for devices the iPod Touch, you have to pay for new major revisions of the firmware, it would cause a legal nightmare they wouldn't be able to dig their way out of anytime soon.

    Yes, Apple is only signing the new 3.1.3 firmware for the iPod Touch 3G and iPhone 3GS, the iPhone 3G, iPod Touch 2G, and iPhone 2G can all downgrade to 3.1.2 without worry since they don't contact Apple.

    Read up on Saurik's Caching Server for jailbroken devices. Just b/c Apple isn't willing to send out the information anymore on older firmwares, doesn't mean that someone else isn't willing to ( though you had to have your device jailbroken before 3.1.3 came out to get the 3.1.2 signature cached ).
    04-02-2010 06:06 PM
  9. mgregg99's Avatar
    I updated to iTunes 9.1 on my Win7 Pro PC and haven't had an issue with my 3Gs 3.12 untethered jailbreak. Everything works the same as it always has with syncing and such. The only difference I noticed is that the backup now takes a long time each time. In the past it would be pretty quick, but maybe they've changed how things are backed up. I've synced three times since the iTunes update and not one problem.

    Mike
    04-02-2010 07:04 PM
  10. bergman's Avatar
    My sync now takes forever too. iTunes 9.1, 3GS jailbroken. The slow sync is aggravating. has anyone found a fix? what about uninstalling 9.1 and reinstalling 9.0?
    04-03-2010 10:04 AM
  11. Mustang5Oh's Avatar
    if it ends up being a issue i'm sure apple will fix it.
    04-03-2010 11:37 PM
LINK TO POST COPIED TO CLIPBOARD